Network manager shows the message "wireless is disabled by hardware switch" while three is no switch on the laptop to disable wireless.

below is the lshw output which might help to get to the solution

  $ sudo lshw -C network
  *-network DISABLED
       description: Wireless interface
       product: Centrino Advanced-N 6200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:0a:00.0
       logical name: wlan0
       version: 35
       serial: 58:94:6b:14:25:c8
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-8-generic firmware= build 25532 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:41 memory:ead00000-ead01fff
| improve this question | | | | |
  • Is this a fresh install?If so, Have you checked for additional drivers? – Binarylife Aug 6 '11 at 15:42
  • it is a fresh install. i did tried this, but the list is empty. (no proprietary drivers available ...) – Tzury Bar Yochay Aug 6 '11 at 15:47

10 Answers 10


That model does have a wireless on/off switch just under the PC card slot, but I'm sure you know that already.

| improve this answer | | | | |
  • I know now, I had to unlock the cover to find this. Thanks! – Tzury Bar Yochay Aug 16 '11 at 3:59

May be there is a Fn + something that works as a hardware switch.

| improve this answer | | | | |
  • it is panasonic toughbook cf-19 I did all fn+X combinations. nothing worked. also tried rfkiil unblock but with no results – Tzury Bar Yochay Aug 6 '11 at 15:45

On my Lenovo V570, I had to first run sudo rfkill unblock all and then blacklist a buggy module.

After the sudo rfkill unblock all, run sudo rfkill list to see what is still blocking wireless.

For example,

3: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no

Find that corresponding module and remove it and blacklist it,


sudo rmmod acer_wmi

and add to a blacklist under /etc/modprobe.d/[filename].conf.

(Relevant bug report)

| improve this answer | | | | |
  • Find that corresponding module and remove it and blacklist it. How do I do that? – zidarsk8 Jun 23 '12 at 13:40

On my Lenovo E530, the wireless didnt work, and rfkill showed it as blocked by hardware. It turned out the wireless LAN radio was turned off in the BIOS. Turning it on solved the problem.

| improve this answer | | | | |

Got the same problem spent lot of time trying different solutions (hard/soft) then just reset bios to factory default and it worked!!

as always if a solution exists has to be simple.....

| improve this answer | | | | |

Try shutting down(if not already off), disconnecting the power, remove battery(if it is a laptop), press power a few times to release stored energy, reinsert battery(if it is a laptop), reconnect AC power. Turn on computer. Worked for me. After trying multiple fixes I found on the internet I remembered reading this somewhere. My hardware was blocked via a hardware switch(fn+f8) which doesn't work in ubuntu(works with windows, but uninstalled windows). rfkill showed 0: phy0: Wireless Lan as Hard Blocked.

| improve this answer | | | | |

I had a similar problem on an HP 635. It was solved by simply connecting the laptop to an ethernet cable. This automatically unblocked the wireless switch, and the wireless started working.

| improve this answer | | | | |

Some laptops have switches that are BARELY noticeable. I have a DELL laptop where the switch is on the right side of the laptop. I accidentally turned it off once (didn't even know it was there) and then accidentally turned it back on and that's how I found out about it. If it's telling you there's a hardware switch, it's probably right. :) You just need to find it. You can Google images of your laptop with the keywords "wi fi switch," "hardware switch," etc.

| improve this answer | | | | |

If you are using Panasonic Toughbook CF-19, go into BIOS > Advanced > and set the "Wireless Switch" option to DISABLED.

Also, if you need, you can uninstall the Panasonic Wireless Switch software after you have disabled the BIOS option as mentioned above.

This fixed my issue of unable to switch on/turn on the wireless or wireless not working.

| improve this answer | | | | |

Resetting BIOS to factory default worked for me with a HP DV4000 and Ubuntu 12

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.