9

I just upgraded from 3.13.0-40 to 3.13.0-43, and now I can't boot- my system hangs at the ubuntu splash screen with the five orange dots. My fans are all running full-tilt, and the system is completely unresponsive- I can't ctrl-alt-f1 into a command prompt.

I'm sure this is related to the upgrade, because I can still boot into 3.13.0-40 just fine. I've tried reinstalling linux-generic and linux-image-generic, it didn't change anything.

When I look in syslog, there appear to be no entries at all from the failed boot.

How can I troubleshoot what it is about this kernel version that's causing my system to hang?

System specs: Ubuntu 14.04, AMD Radeon HD 7750 graphics card, using the open-source drivers

  • If the fans are running full tilt, there is a possible problem with your Graphics driver setup. Can you access terminal with `Ctrl+Alt+F2 after it hangs? – Zbunjeni Dec 11 '14 at 20:15
  • Thanks, but ctrl+alt+f2 had no visible effect. I can't seem to get into the terminal any which way. – Dane Powell Dec 11 '14 at 20:27
  • Try to press the key combo (ctrl+alt+F2 ) as soon you see the GUI splash, in my case i had to login very very fast to get the terminal working and not freeze. – Zbunjeni Dec 11 '14 at 20:29
  • Success! It revealed a kernel panic, stack trace, and a bunch of errors related to the video card. It's a non-interactive shell so I couldn't capture the text, but I got a picture: imgur.com/pHQJRov – Dane Powell Dec 11 '14 at 20:38
  • Ok, did it stay on terminal line or it just hangs at the end? – Zbunjeni Dec 11 '14 at 20:40
2

Introduction

I also had the same problem after an update on a AMD A6-6400 processor with a Radeon HD GPU. Got the black screen of death (BSOD). I was able to boot up (sometimes) holding down the shift key to display the GRUB menu, selecting "Advanced options for Ubuntu" and then selecting a previous version of the kernel (3.13.0-40-generic).

Update V - System rebuild

My AMD processor is mounted on a Gigabyte GA-F2A88XN-blah-blah-blah motherboard with retrofit quiet cooling components. I hate noise. I like this system when it works properly because I can't hear it. Don't suggest I change the hardware. That is not going to happen.

The Old System

I had Ubuntu 14.04 LTS (32 bit) installed with the proprietary fglrx drivers enabled. The open source drivers used too much CPU power. I could hear the fans. The open source drivers sucked.

This fglrx configuration worked fine for about a year. Then the 14.04 automatic updates stopped working. More BSOD bullshit. That kind of thing. Enough is enough.

The New System

The new system started with Ubuntu 15.10 (64 bit) installed with the open-source drivers enabled. Everything seemed to work. I then enabled the fglrx drivers. Everything seemed to work. WooHoo. Time for lunch.

For some reason, after some time had passed, the custom cooling fans began to run at maximum speed. My black box was noisy and annoying.

The sun was shining on the box and it was a warm day, but the CPU should have been napping. Now it sounded like it was competing in the Tour-de-France.

I powered up the TV, turned on the remote keyboard. Make sure the proper HDMI input is selected. This takes probably 45 seconds. The box, meanwhile, is screaming for air. The Black Screen Of Death (BSOD) is the only response. This procedure takes more than 45 seconds.

So I press & hold the front-panel power button. I count to 10. Slowly. Nothing happens. WTF?!? I wait a bit more because I don't know what to do. Never had this happen before.

So then I pull the power cord.

Recovery from this condition is a bit complicated, but it can be done. I would tell you how I did this but I forget now and Your Mileage May Vary (YMMV) anyway. Just ask Volkswagon.

Short version: AMD A6-6400 on a Gigabyte GA-F2A... motherboard? Install Ubuntu 15.10 64 bit. Use the open source drivers. That works best.

Update IV

I have since altered a line in /etc/default/grub from

GRUB_DEFAULT=0

to

GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux 3.13.0-40-generic"

Note the text in the quotation marks is the exact same text as it appears on the 2 levels of GRUB menus. Adjust according to what appears on your own display.

After saving the edit, run the command:

sudo update-grub

This is not a solution of course, just a workaround, but at least it does boot up normally and everything seems to work. I hope a future update will make this problem go away. This last update was a total nightmare!

Update III

The latest kernel update (3.13.0.45) crippled my system. I am now using the latest AMD proprietary drivers and everything works again. This was another painful update. So now I'm thinking of using something other than Ubuntu. Seriously.

Update II

As reported below, the latest Linux kernel update (3.13.0-44) corrected the problem for me because I apparently use the Radeon driver. The problem was reported Dec 14 but it took almost a full month to correct the problem.

But wait! There's more! Apparently Kernel 3.13.0-44 has problems with NVIDIA drivers.

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331-updates/+bug/1409801

Update I

This morning (Jan 13) the software updater downloaded Linux kernel 3.13.0-44. It works on the A6-6400 on reboot. The file /etc/default/grub is back to its original form.

For the record, I also attempted to use several variations of the AMD fglrx suite of packages. It worked with the both the -40 and -43 releases BUT the rendered display was the wrong size! It turned a 50" HD TV into a 46" HD-ready TV. The smaller display was centered within the 50" display area. Very strange.

  • I have a similar machine, and had a similar problem. I just wanted to confirm that updating to the 3.13.0-44 kernel has fixed my issue as well. – snapfractalpop Jan 13 '15 at 18:41
0

1) I chose and boot 3.13.0-39.

2) Then I turned fglrx proprietary

3) And reboot in 3.13.0-43, thats work

P.S. sorry for my googletranslation

P.P.S System: Ubuntu 14.04.1 LTS i686 Kernel: 3.13.0-43-generic DE: Unity Session: ubuntu Processor: Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz Video: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper PRO [Radeon HD 6750] Subsystem: Hightech Information System Ltd. Device 2313 Kernel driver in use: fglrx_pci

  • Thanks, this is more of a workaround than a solution but it's the best idea so far. – Dane Powell Dec 11 '14 at 23:09
  • IMHO the best way to try this is with the Synaptic Package Manager. At least it handles the dependancy issues. That said, there are still problems. – Diogenes Jan 6 '15 at 10:42
0

Same here, Athlon 5150 with radeon R3 (HD8400). Black screen, system freeze during boot, started after upgrade of Ubuntu (this upgrade is included into installation of Ubuntu(!!!) )

Here is the bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1402386

The worse is, the kernel 3.16.0-28 is also plagued by this bug.

0

I'm having the exact same issue with an NVIDIA card (gtx770 and proprietary drivers) and the lowlatency kernel!

I did not have the time to examine the problem here, but the result is the same so they may be related... I'm not able to access any other TTY, but using ssh I was able to conntect to the PC. I hope to find some time tomorrow.

  • I was having issues with an NVIDIA card as well (GTX 750 Ti), I run the drivers available through nvidia.com/object/unix.html. I was able to access TTY so I did a re-install of the latest drivers and it works again. I also came across the following question which has an answer that suggests to install DKMS. Going to give that a shot and see what happens with the next kernel upgrade. – Jason Lewis Dec 16 '14 at 1:25
  • I'm running the official 331-updates from the repo, so no reason for me to use dkms manually.. I've never had any issue like this! – lucaelin Dec 16 '14 at 11:45
  • I'm up and running again by un- and reinstalling the 331-updates package. but the reason is still unclear to me! from what i saw the hole module was unavailable after the update.. strange – lucaelin Dec 16 '14 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.