0

I'm trying to install the Fuze Meeting client which I'm planning to use for Webinars at work. They have a Linux client and make it available through an apt Repository.

Their installation instructions are:

sudo bash -c 'echo "deb http://apt.fuzebox.com/apt $(lsb_release -sc) main" > /etc/apt/sources.list.d/fuzebox.list'
sudo wget -O /etc/apt/trusted.gpg.d/fuzebox.gpg http://apt.fuzebox.com/apt/keyring.gpg
sudo apt-get update
sudo apt-get install fuzelinuxclient

However I'm on Utopic 14.10 and their repository is only current through Trusty. Is there a way to install this software on Utopic even though it is only officially available for older versions of Ubuntu?

I tried replacing $(lsb_release -sc) with trusty in the above steps but I get the following warning when I try to apt-get update.

W: Failed to fetch http://apt.fuzebox.com/apt/dists/trusty/Release Unable to find expected entry 'main/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)

And then this error when I try to install:

E: Unable to locate package fuzelinuxclient

1

You can try. Replace the $(lsb_release -sc) command in their instructions with trusty. Follow the rest of the steps.

However, note that because library versions change from version to version, the Trusty version might not be installable on Utopic, or might not work correctly.

  • I tried that, but I got warnings and errors. I updated the question with them if you could provide any more guidance. – Stephen Ostermiller Dec 11 '14 at 19:52
  • Replace main with rc in /etc/apt/sources.list.d/fuzebox.list. I guess their instructions are very out of date. – saiarcot895 Dec 11 '14 at 19:52
  • That worked. Can you explain why that is necessary? – Stephen Ostermiller Dec 11 '14 at 19:53
  • See the list of folders at http://apt.fuzebox.com/apt/dists/trusty/. The instructions above assume that there's a main folder. However, there's no such folder; instead, there's an rc folder. If you go one up and into Saucy, there is a main folder there. – saiarcot895 Dec 11 '14 at 19:54
  • I'm assuming rc means Release Candidate, so note that you may be using a Release Candidate version, and that there may be bugs. – saiarcot895 Dec 11 '14 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.