1

I have dual boot with ubuntu 14.04 LTS and Windows 8.1. I have 4 ntfs partition in my laptop, one for windows and 3 for my media clips. Sometimes the ntfs partition not showing in my ubuntu, on that time I reboot and saw my ntfs partition in ubuntu panel. But now the ntfs partition now showing, I reboot ubuntu 6 times, but same problems occours, any help?

  • Have you tried to access those partitions from Windows after they gone away from Ubuntu? Maybe they got corrupted so if you boot Windows they should be checked and fixed. – diegov Dec 11 '14 at 18:42
  • 1
    Yap, I can access those drive from my windows. they are working fine with my windows 8.1. But these ntfs drives are not showing in my ubuntu, i reboot my ubuntu a lot of times. but nothing happen. – Talha F. Dec 11 '14 at 20:14
0

I have got a suggestion but I don't know if it will solve the problem or not.
Try booting into Ubuntu again and see if the disks are showing up. If not, try to see if they are at least visible in the Disk Utility or GParted. If they are, then in the Disk Utility, just click on the SMART data and then Run Self-test. If any errors are reported, they may be preventing the disk from being mounted.
After that, try booting into Windows and just checking the NTFS disks (Right click-> properties-> tools-> check). You may wish to start off with the most vigorous check. Then I suggest you do this:
right click on start (or press win + X)-> Choose Command Prompt (Admin)-> Enter the following:

chkdsk /B D:\

Replace D:\ with the drive letters of the drives. You may have to agree to scan on next restart for some drives.
Some errors in the disk are the most probable cause.

0

I had a similar problem: i have an ntfs disk (/dev/sdb) with one single partition. Ubuntu decided that it is 2 partitions and can`t read either one. When i open nautilus, both partitions show up, but neither can be opened.

The device '/dev/sdb2' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition

To mount the disk, i run

sudo mount -o loop,offset=0 /dev/sdb /media/[user]

Change /media/[user] for whatever your username is (verify that subfolder exists).

If you have more than one partition, you should run parted (info here) to establish what the offset for each partition start is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.