3

Is there a way to disable the Caps Lock at boot, so it won't bother me when logging in?

Laptop: old Multicom Xishan W530E bought at http://multicom.no. OS: Ubuntu 14.04.

My latop has a problem with the Caps Lock button. It keeps toggling on/off. It seems like it's a hardware issue, as I experience the same problem on Windows and other distros.

For some reason, the problem does not occur at the disk unlocking screen (?) before the login screen appears.

I've disabled the key with gnome-tweak-tool, and have tried most other fixes I could google up.

My main problem now is how these fixes only seems to work after I've logged into a user account. Writing my password on the log in screen is still at the mercy of the dreadful Caps Lock.

The laptops BIOS settings doesn't have options for the keyboard, as far as I can see.

Thank you for any and all help!

4
  • Hardware problem -> hardware solution... what about a cutter? ;-) (joking, but now fully --- I would really try to remove the key and cut the connection. I never understood the reason to be of the CapsLock key, anyway, if not to be remapped to Compose.).
    – Rmano
    Commented Dec 11, 2014 at 15:32
  • Have you tried any keyboard remapping? For instance check out this How to Answer:(askubuntu.com/questions/296155/…)
    – dagrha
    Commented Dec 11, 2014 at 19:32
  • @dazzle: I've tried remapping, and outright disabling caps lock. It works, but doesn't take effect until I've logged in. I still experience problems at the log in screen.
    – Creutz
    Commented Dec 20, 2014 at 1:24
  • @Rmano: I'd rather try a software fix first, if possible. =] Worst case scenario, it's reversible.
    – Creutz
    Commented Dec 20, 2014 at 1:28

0

You must log in to answer this question.

Browse other questions tagged .