0

I want to install php5-mcrypt, I used this command to install mcrypt on my ubuntu 14.04 server:
sudo apt-get install php5-mcrypt
and I'm getting the error like this,
The following packages have unmet dependencies: php5-mcrypt : Depends: phpapi-20100525 Depends: php5-common (= 5.4.35-1~dotdeb.1) but 5.5.9+dfsg-1ubuntu4.5 is to be installed E: Unable to correct problems, you have held broken packages.
please help me.

  • Try apt-get update --fix-missing && apt-get install -f – aroll605 Dec 11 '14 at 4:32
  • thanks aroll605. i tried that method it didn't work.so i removed phpand installed again on my system. – programmer Dec 12 '14 at 2:43
1

I found answer to my question. I removed php completely in my system using sudo apt-get -y purge php.* and install php again on my system. reference to remove php: How to completely remove PHP?

  • You can mark this question as answered if you solved it. – No Time Dec 12 '14 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.