1

I have two identical desktops running Ubuntu server 14.04. During the install process I only selected Ubuntu server, no other packages.

Desktop #1) This was my first linux build, and so fumbled around quite a bit until I figured it out. I configured the WPA_Supplicant.conf file utilizing the wpa_passphrase program, can can connect fine using wpa_supplicant. I can then get an ip using dhclient, or assign a static address in wpa_supplicant.conf... I also successfully configured the /etc/network/interfaces file .. first to connect via DHCP, then changed it to connect to a static IP. So.. for desktop #1 it works perfect.. connecting to my wireless network via WPA_supplicant manually, or automatically utilizing /etc/network/interfaces on boot.

Desktop #2) This is the problem machine. It is the same model, and same wireless card. I have successfully created the WPA_Supplicant.conf file, and can connect manually by running wpa_supplicant, then of course get an address via dhclient. It works great!!!! However, for the life of me, I can't connect automatically on logon with /etc/network/interfaces. It just doesn't connect! I can't find a single difference between the two machines!

Perhaps I inadvertently changed something on desktop #1 in my banging around to make it connect on logon?

Here is my wpa_supplicant.conf:

network={
ssid="myssid"
#### #psd="mypasscode"
psk=my-very-long-64char-passcode
}

here is my /etc/network/interfaces:

#### #The loopback network interfaces
auto lo
iface lo inet loopback

#### #The primary network interface
auto lo
iface wlan0 inet dhcp
wpa-essid myssid
wpa-psk my-very-long-64char-passcode

note: I have tried the wpa-psk as clear text, as well as 64bit.. either seems to work in desktop 1, neither seem to make a difference in desktop 2.

Any help is appreciated!!!

Oh to connect manually I simple run...

sudo ifconfig wlan0 up
sudo lshw -C network
sudo iwlist scan
sudo wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
dhclient wlan0
  • sudo lshw -C network - to confirm it is enabled
  • sudo iwlist scan - to confirm it can scan
  • sudo wpa_supplicant - to connect
  • dhclient wlan0 - to get IP

this works great on both desktops.. it's just that I can't get desktop #2 to auto connect on logon!!!

Thank you!!

1

In /etc/network/interfaces, the declaration wpa-psk expects the password in clear text, not a 64-bit scrambled version. I suggest you amend your file to:

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wpa-essid myssid
wpa-psk mypasscode

Restart the interface:

sudo ifdown wlan0 && sudo ifup -v wlan0

The '-v' for verbose should produce some output indicating what's happening behind the scenes.

NOTE: "auto lo iface wlan0 inet dhcp" is incorrect. See my suggestion above.

  • Thanks.. I changed it back to clear text.. same thing. :( – Paul Dec 11 '14 at 13:12
  • Meaning what? Meaning it won't connect at all or it won't connect on boot? – chili555 Dec 11 '14 at 14:03
  • Hi chili555 - sorry.. fist, my bad.. typo on auto lo.. my interfaces file is actually auto wlan0.. so that's not it. :( – Paul Dec 12 '14 at 0:56
  • As for a clearer definition of the symptoms (apologies).. it will not connect on logon. I can still connect manually, but not on logon. Interestingly, I have to clear out the interfaces file (comment out the lines) in order to connect manually. Otherwise, if I boot with the interfaces file (and it fails) I can't connect manually. I HAVE to log on without the system attempting to connect with interfaces in order to be able to connect manually. – Paul Dec 12 '14 at 0:58
  • Is Network Manager running? ps aux | grep -i network If so, it probably needs to be purged. – chili555 Dec 12 '14 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.