I have a Fujitsu laptop and all was working fine until I ended teamviewer. On the keyboard it has a numberpad on some of the letters which you press the Fn button to use. The system is acting like I have the Fn key pressed and I get numbers shown when it should be letters. If I press the Fn key the numbers go to letters. The Fn key is not stuck down. Is there a way to reset keyboard settings or a known fix. The operating system is Ubuntu 11.04 Natty.

  • thanx is the numlock turn on i turned off and keyboard work fine agine – user52619 Mar 29 '12 at 17:34
  • When I turn off numlock part of my keyboard acts like external numeric keyboard and instead of numbers or letter I got the arrows, Home, Page UP etc. Whem I numlock on again I got the numbers, but never letters. Any help here? – Kostanos May 6 '15 at 22:26

10 Answers 10


The Fn key is generally handled via the ACPI BIOS rather than directly by the operating system, so there is unlikely to be anything that Ubuntu itself can do.

One possibility is that you've turned on the NumLock, which might cause those keys to default to numbers instead of letters. Hitting the key (or key combo: on my laptop Number Lock is toggled by the Fn+ScrLk key combo) again should set things back to normal.

If that doesn't work, restarting the system will probably return it to the default state.

| improve this answer | |
  • On ASUSPRO series I got this same behaviour. fn+num lk keys restored my keyboard back to normal. – Awi May 22 '14 at 19:19

Had the same issue with DELL Inspiron 15 5000 Series :

Solution is to press Fn+Esc.

| improve this answer | |
  • Working on Dell XPS 15 Debian 9 Gnome too – Basti Destruction Mar 27 '18 at 19:42
  • +1 Intel new NUC system. Dell Keyboard (KB216t). This is the only solution that worked for me. Note that the [Esc] key has a little lock icon on it. – arielf Feb 5 '19 at 5:00
  • Solved the issue on my Dell Latitude 3550 as well. – sergico Mar 7 '19 at 21:52
  • solved the issue on my Dell latitude 3470! Thank you! – void Jun 30 '19 at 9:48

On samsung laptop, there are "Fn Lock" button on right-top of the keyboard so that it fixed.

| improve this answer | |
  • 4
    On Lenovo it is on the Esc key. I.e. Fn + Esc toggles the behaviour of the Fn key. (BTW, same behaviour in Windows; I could find nothing in the bios.) – Darren Cook Mar 29 '14 at 13:26
  • So it can be different way on different vendors :-) – Romy Prazhad Apr 8 '14 at 10:08

On Asus Zen Book the magic key combination is FN+Insert.

| improve this answer | |
  • I confirm this on my Zen Book running Ubuntu. – SaTa Aug 30 '19 at 23:41

For me, I had only to press Fn with F11. This combination enable/disable the num lock in notebook keyboard!

Otherwise you can try another combination in your keyboard to enable/disable num lock.

| improve this answer | |

I found that the Num Lock is the issue here. I had the same issue, and I turned off num lock and it worked fine for me after. It's because that's what registers as a normal number pad, and instead of hitting Fn, num lock automatically replaces the Fn key.

Its a derp, but fixable easily.

| improve this answer | |

I was having trouble with this.. Turns out there was a Fn-lock-button on my keyboard up by F12... silly me missed it.

| improve this answer | |

I just found out that there is "Fn Lock" key on my samsung laptop. And I pushed this key by mistake and it was react exactly like you described.

So, if you have this key, just press on it one more time and it will be fixed.

| improve this answer | |

My laptop (Asus EEE 10") had this exact problem; pressing the numlock key (which required the fn key in this case) fixed it.

The interesting thing though, is that before I figured it out, the problem persisted after reboots, but only happened in her user. So apparently Ubuntu saves the numlock state (per user) across reboots. It's an old version (10.04) so I don't know if this is still the case.

| improve this answer | |

I had this issue to on my laptop. It seems that pressing Fn+Num Lk on my keyboard locks the Fn key as pressed (pressing it makes it act as unpressed). I was probably hitting Fn+Num Lk accidentally due to the ackward keyboard layout of the laptop.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.