1

I'm newly back to Linux after >20 years. First install was with a beta kernel in ~1992.

I've build a home media server with a 4-drive RAID 5 array with the latest workstation version of Ubuntu (server install failed!?!). Set it up fine and started copying files to it with no problem.

Upon a reboot, the drive is gone, so I assume I didn't set something up properly to remount the drive upon reboot.

I tried:

mdadm --assemble --scan

and nothing happens - no error message, and no array.

Then I tried:

mdadm --assemble /dev/md0 /dev/sdb /dev/sdc /dev/sdd /dev/sde
mdadm: /dev/sdb is busy - skipping
mdadm: /dev/sdc is busy - skipping
mdadm: Cannot assemble mbr metadata on /dev/sdd
mdadm: /dev/sdd has no superblock - assembly aborted

Does this mean that somehow /dev/sdd became damaged? Is there anything I can do short of repartitioning /dev/sdd?
The drives are all brand new - how can I check to see if the drive is bad?

Any help much appreciated!!

Mike

  • It is always better to make one question per expected answer. For the health status you can install smartmontools (sudo apt-get install smartmontools ) Now sudo smartctl -H /dev/sda will give you the health status of the drive itself. – Requist Dec 10 '14 at 15:32
  • Thanks much @Requist. Checked all drives and they pass SMART assessment. Does this mean that the superblock from /dev/sdd was somehow trashed? – Mike Dec 11 '14 at 7:00
  • No, I presume the RAID is ok, just not automatically started. However, I am not very experienced with RAID and we use a hardware raid with its own tooling, so on that part I am not the best help. You should check how the RAID was made and what could be forgotten. – Requist Dec 11 '14 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.