315

I'm having serious problems installing the Broadcom drivers for Ubuntu. It worked perfectly on my previous version, but now, it is impossible.

What are the steps to install Broadcom wireless drivers for a BCM43xx card?

I'm a user with no advance knowledge in Linux, so I would need clear explanations on how to make, compile, etc.


lspci -vnn | grep Network showed:

Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] 

iwconfig showed:

lo        no wireless extensions.
eth0      no wireless extensions.

NOTE: Answer below is updated every time new information is added and confirmed working.

  • 1
    help.ubuntu.com/community/WifiDocs/Driver/bcm43xx - there you can see that Broadcom STA driver should work with BCM4313 (:BCM4311, BCM4312, BCM4313, BCM4321, BCM4322, BCM43224, BCM43225 ) Which Ubuntu you are using? – Hillar Nov 10 '10 at 11:12
  • 10.10, by the way, i tried those steps before and the card installed fine, but with the low speed problem – Ataraxio Panzetta Nov 10 '10 at 18:31
  • There's a bug report here concerning that Broadcom chip in Natty that similar to what you're experiencing. I'm not sure if this has been resolved. – boehj Apr 30 '11 at 8:13
  • You can try to use Broadcoms hybrid driver with patch. hope this article from mindwerks can help you to solve your problem. – neyz Jun 28 '11 at 19:08
  • The point of Ask Ubuntu is to collect answers, not links to answers. I will only manually award the bounty to a question that provides a step-by-step solution to make the BCM4313 work (if that works for similar chipsets too, that's fine and should be noted). Also, please make sure that you tested the answer yourself and are not just copying-&-pasting something from the net. Thanks! – htorque Oct 11 '11 at 10:17

42 Answers 42

0

Install the package bcmwl-kernel-source

0

I installed Ubuntu 11.04 from scratch on a Dell Latitude 131L with Broadcom bcm4311. The Proprietary driver Broadcom STA was installed by default and Fn+F2 that was the only thing that I had to use to enable Wifi in 10.04; in 10.10 it didn't work. I found this page and tried a few things:

  • removed the Proprietary driver in Hardware drivers under System->Administration->Additional Drivers: sudo apt-get install --reinstall bcmwl-kernel-source and removed the line in blacklist.conf.
  • added the driver in System->Administration->Additional drivers
  • reboot.

This did not work.

  1. After this I added the line in /etc/modprobe.d/blacklist.conf again: replaced by b43 and ssb. Blacklist bcm43xx.
  2. Removed the proprietary driver from system->administration->hardware drivers
  3. After a reboot, the wifi works!

My guess is that only the steps in 1-3 are needed.

0

"Installer Package for firmware for the b34 driver" installation package worked well for me on a HP Pavilion DV5000

0

I had the same problem and found the solution. Run the following command and reboot the machine. This worked for me.

echo 'options acer_wmi wireless=1' | sudo tee /etc/modprobe.d/acer_wmi.conf
  • OP owns a Lenovo machine, I'm not sure if it works. To test it without rebooting, run echo 1 | sudo tee /sys/module/acer_wmi/parameters/wireless. If it works, run the command as descriebd in the answer. – Lekensteyn Jul 7 '11 at 10:14
  • I've got a message: No such file or directory – Justas Jul 11 '11 at 19:14
0

Had the same slow connection issue with Ubuntu 11.04 and a HP Mini 5103 laptop which comes with Broadcom 4313. After having tried many suggestions, disabling the Broadcom STA Wireless Driver from Additional Drivers window fixed the issue for me.

0

For people having a Dell Vostro 1320 (or similar) and experiencing a notification in the wireless menu about a turned off wireless, this is what helped me.

The dell_laptop module was interfering with rfkill and telling it incorrectly that the hardware switch is off. This can be fixed by blacklisting the dell_laptop module. Open the file /etc/modprobe.d/blacklist.conf with your favorite editor with superuser permissions, e.g. press ALT+F2 and type

gksu gedit /etc/modprobe.d/blacklist.conf

or in a Terminal:

sudo nano /etc/modprobe.d/blacklist.conf 

At the end of the file ad the following like (preferably with a comment):

# dell_laptop communicates wrong hw switch state to rfkill 
blacklist dell_laptop 

Don't forget to save the file. After blacklisting the module this way it will not be loaded during future system startups. Reboot your machine. Wireless should work now.

reference: http://launchpad.net/bugs/701259

0

I had the same problem. b43 and bcmwl didn't work for me. b43 worked but the speed was always below 10kBps.

The open source bcma driver works fine.

sudo rmmod wl
sudo modprobe bcma
sudo reboot

This did the trick for me.

0

After several hours of trial and error I finally found a solution for "Debian Wheezy (testing)" !! - I think it should work similar on other distributions too. The main problem was the driver brcm80211 (provided by package "firmware-brcm80211") - now I use the driver wl provided by the package "broadcom-sta-dkms" and everything works !

Instructions:

add

deb http://ftp.us.debian.org/debian wheezy main contrib non-free

to

/etc/apt/sources.list

then do

apt-get update

afterwards do

apt-get install broadcom-sta-dkms

now unload conflicting modules

modprobe -r b44 b43 b43legacy ssb brcmsmac

please note: your existing WLAN connection will terminate doing this!

load wl module with

modprobe wl

verify your WLAN chip is working:

iwconfig

configure your WLAN interface as usual - finished! :)

(source: http://wiki.debian.org/wl)

0

The Broadcom STA drivers worked OK for me, and I have the same Broadcom card in my Dell. The slow Internet connection I felt was during powersave mode. Here are the list of Broadcom drivers available. I have been using the opensource driver since then, and I recommend it over the STA drivers.

People say it is not available for Ubuntu 10.10 (Maverick Meerkat), so you need to install it manually. Ask Ubuntu question Broadcom STA driver doesn't work well with BCM4313 provides information on installing it manually OR you can may be use the Debian builds.

0

I have a HP Pavilion dv6000.

I had this issue while installing Ubuntu 11.10 (Oneiric Ocelot), and the post b43 - No Internet access helped me a lot.

Specially when you don't have a wired network available on your laptop. All you need is a pendrive with Ubuntu 11.10 (Oneiric Ocelot) and two files which you can download from a computer with Internet connection (copy them to your pendrive):

  1. http://downloads.openwrt.org/sources/wl_apsta-3.130.20.0.o
  2. http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2

Follow the instructions on the site I mention above, and don't forget to restart your computer (I skipped step 4 - it worked after the restart).

0

Special case: BCM43142 & AR8161 on Dell Vostro 3460

The Intel4000 graphic in my case needs at least kernel 3.6 (for 64-bit: 1,2,3,4). There the needed kernel headers for the Broadcom adapter are included. But the problem is that before installing the kernel, you need to install the build-essential, and this is differing between Ubuntu release versions and window managers. You also need to install the dkms if not already available, too, which is a bit tricky without an Internet connection. So here comes a hint for other noobs like me that I grabbed from here:

  • Install your ...buntu of choice (Linux Mint also works) on a machine where you can access the Internet out-of-the-box (for example, on USB and visit a good, old friend with some easter eggs ;)

  • There you sudo apt-get install build-essential dkms

  • Go to /var/cache/apt/archives (at this location apt automatically stores all your installed packages per default.) Now copy all deb's into a folder, for example, called "BUILD-ESSE" on your USB stick.

  • Now you easily can copy this folder on your Vostro and install those debs via sudo dpkg -i BUILD-ESSE/*.deb.

0

I solved problem on HP Pavilion g6 with Broadcom 4313 (14e4:4727 rev 1) by removing blacklist on bcma and brcmsmac

Instructions

Install drivers and firmware

sudo apt-get install broadcom-sta-common linux-firmware

Remove blacklist by editing /etc/modprobe.d/broadcom-sta-common.conf (e.g. commenting lines) :

blacklist b43
blacklist b43legacy
blacklist b44
#blacklist bcma
blacklist brcm80211
#blacklist brcmsmac
blacklist ssb
install wl /sbin/modprobe --ignore-install wl $CMDLINE_OPTS

The example above may differ from your original file

Backup the original file

  • If you removed bcmwl-kernel-source, this conf file would be removed altogether, and the problem solved. – Pilot6 Feb 3 at 12:44
  • bcmwl-kernel-source was already purged from my system – lauhub Feb 4 at 1:40
  • That file /etc/modprobe.d/broadcom-sta-common.conf came from that package, or broadcom-sta-dkms that is actually almost the same package. – Pilot6 Feb 4 at 18:00

protected by RolandiXor Aug 8 '12 at 15:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.