0

I am using Ubuntu 14.04 Trusty Tahr, and when I have a terminal open with multiple tabs I can cycle through them (for me, using Shift + arrow keys). Currently it will wrap around the edges, meaning that if I am on tab 1 and hit Shift + left, it will go to the last tab, and vice versa. I don't want that. I don't want it to wrap. Searching for this question led me to someone else who asked this question for 9.04, and the answer was to add the line gtk-keynav-wrap-around = 0 to ~/.gtkrc-2.0 . This file did not exist for me, so I created the file and put only that line in it. However, after restarting my machine to ensure any changes would be pushed through, it has not helped anything. Does anyone know how to make this simple change?

5
  • Trusty uses gtk3 so this solution is not going to work. Maybe the equivalent is something like .gtkrc-3.x (where x would be the exact version). Dec 9, 2014 at 21:38
  • Or ~/.config/gtk-3.0/settings.ini
    – muru
    Dec 9, 2014 at 21:41
  • @darent I tried creating a .gtkrc-3.0 file (which seems to be the gtk version I have), but again it didn't do anything. Thanks for the idea.
    – soulish
    Dec 9, 2014 at 22:12
  • @muru I also tried setting that line in ~/.config/gtk-3.0/settings.ini and it also didn't work. Thanks for the idea.
    – soulish
    Dec 9, 2014 at 22:13
  • The problem here is that gtk3 had so many changes from from gtk2 that the settings may not use the same files, nor syntax. Dec 9, 2014 at 22:33

1 Answer 1

1

You are out of luck:

GtkSettings:gtk-keynav-wrap-around has been deprecated since version 3.10 and should not be used in newly-written code. This setting is ignored.

While gnome-terminal in Ubuntu is only 3.6.2, libgtk-3-0 is 3.10.8.

5
  • Hmmm. That seems really dumb. Why shouldn't I be able to configure my terminal to act the way I want it to? Thanks for the help, I'm just sad that I'm not allowed to configure my terminal properly.
    – soulish
    Dec 9, 2014 at 22:33
  • @soulish The restructuring that followed GNOME3 resulted in the loss of a lot of features, which are slowly making their way back. In this case, though, I suppose the devs considered that feature to be not popular enough to maintain. You could try filing a bug to see whether there's an alternative, or if there are plans on bringing it back.
    – muru
    Dec 9, 2014 at 22:39
  • Thanks, but even if I knew where to complain, I doubt they consider it a bug. If they chose to take it out, then that seems to be something they don't want. It would be two lines of code. That it no longer exists would imply they chose to remove it, not that it was causing issues. Thanks anyways.
    – soulish
    Dec 9, 2014 at 23:07
  • @soulish If you do consider filing a bug, it would be here: bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B
    – muru
    Dec 9, 2014 at 23:09
  • Thanks. I might as well file one, then at least I can let them know someone wants this changed back.
    – soulish
    Dec 9, 2014 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.