0

This is what my picture would look like if I was allowed to post pictures...

Account Type Administrator

Language English (New Zealand)

Login Options [blank]

Password ****

Last Login Logged in

My Account is the only account - the administrator account - and the blank space is there whether the dialog box is locked or unlocked, as is the complete absence of the Auto Login option at the bottom.

I have 14.04 installed. I have 3 drives, so researching through the other login questions suggests that my drive might be encrypted. If it is, I need simple to follow steps to fix this so Ubuntu will auto login.

All I want is for Ubuntu to auto login on startup. None of the other questions in the forums has been helpful.

This question seems to ask the same question as this: Ubuntu 14.10 Auto Login I'm wondering now if this is a serious flaw in 14 that can't be fixed, or changed. This seems to provide the answer for 12.04 - would it likely be the same for 14? How can I enable autologin for my user account when the option is not there?

Output for:

$ sudo lsblk -o NAME,TYPE,UUID,MOUNTPOINT:

NAME   TYPE UUID                                 MOUNTPOINT
sda    disk                                      
└─sda1 part E8325C83325C58A0                         
sdb    disk                                      
├─sdb1 part 7e9949df-0e95-45f1-919d-23b449f415fd /    
├─sdb2 part                                          
├─sdb3 part CA66EB5F66EB4AB1                     /mnt/CA66EB5F66EB4AB1    
├─sdb4 part                                         
└─sdb5 part 4868A0F868A0E5C2                     


$ cat /home/.ecryptfs/$USER/.ecryptfs/Private.mnt
/home/warwick
  • 1
    Did you even try the steps in that last question? – muru Dec 9 '14 at 20:34
  • @muru I'll be honest with you. I'm just too scared to. I've used terminal before for downloading or editing files (desktop picture changer in 12.04), but this seems like a job I don't want to touch. Partly because someone else installed 14.04 and one of the drives is for Windows. Also, because as administrator, I would expect this option to be available no matter what. – Warwick Dec 9 '14 at 21:23
  • Autologin and encryption are mutually exclusive, so what you expect is wrong. First, let us determine if you have whole disk encryption or just home directory encryption. Please post the output of sudo lsblk -o NAME,TYPE,UUID,MOUNTPOINT and cat /home/.ecryptfs/$USER/.ecryptfs/Private.mnt. – muru Dec 9 '14 at 21:33
  • Question edited – Warwick Dec 9 '14 at 22:09
  • Ok, looks like you only have home-folder encryption. I examined the commands in that answer, and they all look applicable to 14.04 as well. However, where the user does rm, I'd advise you to use mv (e.g., mv /home/user /home/user-bak), so that you retain the original. And your kernel version would 3.13-something. That would be the only differences. – muru Dec 9 '14 at 22:13
1

Go to System Settings > User Accounts. Make sure to press Lock / Unlock in the upper right corner of the window. Then you can use the switch to enable Automatic-Login.

enter image description here

If you are using home folder encryption auto-login is not reasonable. But you can disable encryption if you follow the steps of the answer to the second linked question.

  • The automatic login option is not available whether the dialog box is locked or unlocked. – Warwick Dec 9 '14 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.