5

Hi all I'm trying to install the new omega drivers for Ubuntu 14.04

AMD Catalyst™ 14.12

But the ubuntu software center is complaining "Dependency is not satisfiable: fglrx-core"

I'm downloading this package.

http://www2.ati.com/drivers/linux/fglrx_14.501-0ubuntu1_amd64_UB_14.01.deb

  • 3
    You need to download multiple deb packages from AMD's site. – dobey Dec 9 '14 at 18:40
  • So basically all packes that have 14.04 in them? Also which one do I install first? – user1766555 Dec 9 '14 at 18:43
  • 4
    You probably need to install them at the same time. AMD should provide instructions on how to install them. You probably don't need all the packages, but you will need most of them. You can download them to a directory and then run sudo dpkg -i *.deb in that directory to install them. – dobey Dec 9 '14 at 20:49
  • Also: askubuntu.com/a/568524/178596 – Wilf Mar 2 '15 at 18:40
4

I had the same result, but I got it to work. Instead of the Ubuntu packages, get the generic "Linux (32-bit & 64-bit)" which is 148 MB zip file. Unzip and then sudo ./amd-driver-installer-14.501.1003-x86.x86_64.run. Choose to build packages for Trusty. It takes several minutes and doesn't seem to be doing anything, but just wait for it.

Then when I tried sudo dpkg -i *.deb with the resulting files it told me there was a conflict so I had to do apt-get remove ocl-icd-libopencl1:amd64 before it would work. But then the 4 .deb files installed without error.


sudo aticonfig --initial and reboot. flgrxinfo now reports:
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7700 Series
OpenGL version string: 4.4.13283 Compatibility Profile Context 14.501.1003

Seems to work but the catalyst control center won't start.

Edit: I tried Counter Strike in Steam and it ran very smooth. Much better than before but I think I had a broken driver install before.

Edit2: My chrome://gpu/ used to show all red / disabled and now only "Multiple Raster Threads" is disabled. Everything else is green. Full screen 60fps youtube is buttery smooth with no tearing.

Edit3: download separate amdcccle.deb package from amd site and reinstall it with Gdebi or Software centre, then Catalyst Control Cetntre will start.

3

fglrx-core seems to be the named "minimal driver" on amd website's page for ubuntu_64Bit, and here's the download link (accessible on December 31,2014):

Direct link (for ubuntu 14.04 64bit): http://www2.ati.com/drivers/linux/fglrx-core_14.501-0ubuntu1_amd64_UB_14.01.deb

Download page: http://support.amd.com/en-us/download/desktop?os=Ubuntu%20x86%2064

  • AMD does not seem to allow direct external links: You were linked to this download from a site outside of AMD.com – dotbugfix Mar 29 '15 at 1:42

protected by Community Dec 11 '14 at 2:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.