0

I do not know where to start. This has been frustrating. Today, december 2014, I own an Alienware 14, it uses an NVIDIA GK107M [GeForce GT 750M] and an Intel Corporation 4th Gen Core Processor Integrated Graphics Controller. It uses the optimus technology.

I work a lot with openGL and I have not managed to install nvidia drivers other than nouveau and they are not even being recognized eventhough the module is loaded.

Additionaly my libmesa is giving me hell and in the event I get to compile an opngl application it shows a black screen where a month ago I could render pretty stuff.

I have tried installing nvidia privative drivers and both registering them and not registering them in the dkms modules. I have blacklisted nouveau and even intel drivers.

I am stuck in a dilemma. If I get to work with intel graphics, only openGL <= 3 will be supported and only if I get to work my nvidia card I will be able to work with openGL > 4

I've been searching for days for this issues and have tried almost everything I can, I even reinstalled ubuntu. I've worked with linux ever since I own a computer and I don't want to work on windows just because of this.

Please help me.

  • Have you tried using nvidia-prime & nvidia-331? Works here to use nvidia on a 755m though thru prime there is no chance of vsync – doug Dec 9 '14 at 17:03
  • How do I use nvidia-prime? – Zloy Smiertniy Dec 9 '14 at 17:25
  • I found out how, it was super useful, Thankyou – Zloy Smiertniy Dec 9 '14 at 19:20
1

Well. Through a lot of investigation I found out this problem is at least 2 years old and in those 2 years a lot of very VERY smart cookies managed to make the optimus techonology work and make it easy for us plain regular human beings.

I found a tutorial in french here

It works only for 13.10 and after.

First uninstall anything that was garbage

sudo apt-get purge bumblebee* primus libvdpau-va-gl1

install nvidia-prime and the drivers and the mesa utilities

sudo apt-get install nvidia-331 nvidia-prime mesa-utils

*optional install drivers to watch hd videos

sudo apt-get install vdpau-va-driver

Restart machine

choose wether to use nvidia or intelgraphics in the nvidia-settings. This will have to be done manually all the time.

Other information about Optimus here I found out nvidia is conencted to intel grpahics so in windows it changes automatically when needed to optimize battery life. There is no automatic change in linux but at least you are able to change it manually. Now I can work with openGL 4 in my ubuntu. Now I need to be able to work wiht openGL 3 too.

  • I don't get the deal in ubuntu/linux concerning OpenGL versions. Though here it does show on 14.04 - OpenGL vendor string: Intel Open Source Technology Center OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.1.3 OpenGL core profile shading language version string: 3.30 – doug Dec 9 '14 at 21:04
  • When I change between Intel and nVidia using prime I have these: ---Intel: -OpenGL vendor string: Intel Open Source Technology Center -OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile -OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.1.3 ---nVidia: -OpenGL version string: 4.4.0 NVIDIA 331.38 -OpenGL renderer string: GeForce GT 750M/PCIe/SSE2 -OpenGL core profile version string: 4.3.0 NVIDIA 331.38 Now my opengl 4 applications work but the ones with 3 (intel) dont work. Gives me a black screen and I am just trying to draw some points – Zloy Smiertniy Dec 10 '14 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.