2

I'm trying to create a QML app with a C++ backend using the Ubuntu SDK (Qt Creator).

There is a template called 'App with QML Extension Library'

When I run this using the Desktop kit it compiles and runs fine.

When I run this using the UbuntuSDK for armhf (GCC ubuntu-sdk-14.04-trusty) kit it fails.

The output under general messages shows:

Could not find intltool-merge, please install the intltool package -- Configuring incomplete, errors occurred!

I don't quite understand what's wrong because the intltool package is installed:

sudo apt-get install intltool

Returns:

intltool is already the newest version.

I'm running Ubuntu 14.04 with the Ubuntu SDK (qtcreator-plugin-ubuntu 3.1.1+15.04.20141117.2-0ubuntu1~0trutsty1) which is built upon Qt Creator 3.1.1.

What do I need to do to get it running?

2

You need to install intltool in the chroot in which you're building your binaries.

In Qt Creator, select Tools > Options... and choose the Ubuntu item from the list at left. Select the Click tag, and then click the Maintain button next to the appropriate build target. This will open a terminal with a root shell inside the chroot. From here, use apt-get to install intltool and whatever else you need to compile your project. If you have multiple chroots, repeat this with each.

| improve this answer | |
  • This solved my problem. I'm assuming that a kit is similar to a virtual machine and that having intltool installed on the machine running Qt Creator is not enough and that it also has to be installed on the virtual machine/kit. – RudderDuck Dec 10 '14 at 14:34
  • Yes, the kit contains a chroot (change root). Programs running within the chroot can only see the parts of the file system exposed to the chroot, so you need your tools installed there. Although pedants will object, it's sort of like a very light-weight VM. These chroots are set up to compile for different architectures, so you can compile for your armhf device on your x86 desktop. – Robert Schroll Dec 10 '14 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.