1

I'm running into quite a dilemma, where I'm unable to create a new partition table on a particular SSD (Samsung 840 EVO). Attempting to create a msdos partition table via gparted doesn't work, and I've search high and low for an answer. Even tried diskpart from a Windows disc, but it would only indicate that the partition table is good and once I run up the installer, the installation fails (failed to create a partition). Installing and running Windows on the SSD works fine, and installing 14.04.1 on one of the HDDs in the system works, but not on the SSD.

In GParted is just indicates a warning that "/dev/sda: unrecognised disk label". I've only ever installed a Fedora LVM on the SSD once but it was wiped, and have never had any success with it since.

If anyone could shed some light on this, I would greatly appreciate it.

Thanks


Update 13/12/14: I've RMA'd the SSD, and will update again once I get my replacement in.

  • 1
    How did you wipe it? – Virusboy Dec 9 '14 at 15:25
  • "doesn't work" is not an error description. What does gparted say after you try to create a partition table? – psusi Dec 9 '14 at 16:37
  • The funny thing is that it doesn't actually give me an error message. I go Device>Create Partition Table... then click apple for a msdos table and nothing happens. As if it didn't create a table at all. – Benjamin Delibasic Dec 10 '14 at 0:16
  • @Virusboy To be honest I don't recall what I used. It may have been another installer, and I didn't remove the LVM group before the wipe. Any chance that may be the issue? – Benjamin Delibasic Dec 10 '14 at 1:17
  • Try doing a full format – Virusboy Dec 10 '14 at 1:18
0

If you're using Ubuntu, you can just use Disks (It's installed by default and on liveCD) to create a new partition table by formatting the whole drive. I've never used a Samsung SSD, but sometimes on Intel SSDs updating firmware can solve a lot of issues.

  • Thanks for the reply. I've tried using Disks, but it also failed. "Error formatting volume" Error synchronizing after formatting with type 'ext4': timed out waiting for object (udisks-error-quark, 0) Also noticed that the other HDDs are seen as Free Space while for this SSD is comes up as 500GB unknown. – Benjamin Delibasic Dec 10 '14 at 0:23
  • Just checked and the SSD is already on its latest firmware, so I can rule that out. – Benjamin Delibasic Dec 10 '14 at 2:14
  • Found something here [askubuntu.com](askubuntu.com/questions/530616/… - that may help). Using Fdisk in terminal may work. Post back with the errors you get if any. Also, check the cables (I know..) and if you're using USB, try doing it through a SATA connection if at all possible. – adamclmns Dec 11 '14 at 12:49
  • Tried using fdisk and I'm getting "Disk /dev/sda doesn't contain a valid partition table". Although I've noticed in the Ubuntu installer, the other SSD and HDD are under (0,0,0) but the one that doesn't work is (0,1,0). Tried to search up what it means but I'm struggling to find info on it. – Benjamin Delibasic Dec 11 '14 at 13:05
  • This sounds similar to your issue. Give it a try and see if ti works for you. linuxquestions.org/questions/linux-hardware-18/… – adamclmns Dec 12 '14 at 14:30
0

Update:

I've received my replacement SSD but was still experiencing the same issues. It turned out that in my BIOS (gigabyte fx990 ud3 rev 4.0) OnChip SATA Port4/5 Type was set to IDE instead of as SATA type.

Only the Samsung 840 EVO had the problem being run as IDE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.