1

I have to run a grafic application on ubuntu 12.04 LTS from my Web App. All works greate, but every time I boot the pc, I must run "xhost +" comand on terminal to execute the application.

If I run the application from terminal, all starts, but from the Web App no. Is there a solution to avoid to tipe this comand everty time?

1

Thanks for the replay! I have found the solution. If someone could be interested, this is my solution: My problem was that at every reboot I had to run the xhost + comand. So I created a script with this line and I put it in the Startup Applications. Now works:)

Bye

0

You can install "Unity desktop" to enabled GUI

sudo apt-get install --no-install-recommends ubuntu-desktop

If you are looking for light weighted GUI, possibly you can try "Gnome" GUI, which can be installed using the below command,

sudo apt-get install xorg gnome-core gnome-system-tools gnome-app-install
  • Hi, I have tried both solution. Ubuntu-desktop was just installed. The second, I have installed but nothing is changed. – user1331311 Dec 9 '14 at 11:47
0

Try edit the below configuration file with some text editor,

/etc/init/rc-sysinit.conf 

and make sure below attribute is set to 2

DEFAULT_RUNLEVEL=2 

Save the file and do a restart.

Now check system is showing with GUI,

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.