4

When I do ssh root@ip_adress I receive password request through 7-8 seconds waiting. It happens when I do it with keys too.

This is not server side problem I'm sure(Centos or Debian connecting to the same server instantly). That's what I took to solve the problem:

Deleted «session optional pam_motd.so» from /etc/pam.d/login and /etc/pam.d/sshd UseDNS no in /etc/pam.d/sshd And it's not working

*sorry for my English

When I started /usr/sbin/sshd -d -d -d then ssh -v host I got this:

debug1: No valid Key exchange context   debug1: Next authentication method: gssapi-with-mic 
**WAIT 3-4 Sec**
debug1: Unspecified GSS failure. Minor code may provide more       information No Kerberos credentials available
**WAIT 2-3 Sec**      
debug1: Unspecified GSS failure. Minor code may provide more       information No Kerberos credentials available W debug1: Unspecified  GSS failure. Minor code may provide more information 
**WAIT 2-3 Sec**   
debug1: Unspecified GSS failure. Minor code may provide more       information No Kerberos credentials available 
**WAIT 2-3 Sec**     
debug1: Next authentication method: publickey 
debug1: Offering RSA       public key: /root/.ssh/id_rsa debug1: Authentications that can       continue: publickey,gssapi-keyex,gssapi-with-mic,password 
debug1:       Trying private key: /root/.ssh/id_dsa debug1: Trying private key:       /root/.ssh/id_ecdsa debug1: Trying private key: /root/.ssh/id_ed25519
  • The debug output is all on one line so I can't even edit it easily to fix it - are you able to re-post that and use the "code" button to format it as code? – thomasrutter Dec 9 '14 at 6:24
  • Sorry. It's fixed – c ccx Dec 9 '14 at 13:09
  • What's telling you tail -f /var/log/auth.log on the server? – davidbaumann Dec 9 '14 at 14:05
  • You should post your solution as an answer. Not as an edit to the original post. – Elder Geek Dec 12 '14 at 20:48
  • possible duplicate of SSH Daemon readiness problem – Eric Carvalho Dec 15 '14 at 11:04
7

Problem solved by adding GSSAPIAuthentication no to /etc/ssh/ssh_config.

  • To clarify, setting GSSAPIAuthentication no on the host Ubuntu system solves this. – Nate Nov 28 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.