0

*display

description: VGAcompatible controller
product: RS780M [MobilityRadeonHD 3200]
vendor: Hynix Semiconductor Hyundai Electronics
physical ID: 5
bus info: pci@0000:01:05:0
version: 00
width: 32 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver radeon latency=00
resources: irq:18 memory: 89999999-8fffffff ioport: 5000 (size=256) memory: 94300000-94300000-9430ffff memory94200000-942fffff

Hello again, I tried everything, but nothing worked. I even tried looking for more fglrx files after reading the pages you linked to. I found two and deleted them then tried installing the driver again, but got a huge list of unmet dependencies "livetex".... 2013 version needed.... 2009 about to be installed".

The only way I think I can get it to work is by reinstalling 12.04 from disk but my DVD player doesn't work. Can't boot up with USB because I lost my bios password. "Great". I still like Ubuntu but next time instead of reading ubuntu 'release notes' before upgrading, I think I will google with the websites that you linked to and read the compatibility pages that I found the other day.

You have been a great help and I give you my thanks! I think your suggestions should have fixed the problem so I am going to mark the question as "answered". I think there was just something a little off with my installation. I hope you have a great weekend and a great Holiday season!

  • to debug what's going on press ctrl + alt + f3 and run the command sudo service lightdm restart then, return to ctrl + alt + f3 to read the output. The xsession will start on ctrl + alt + f7 or f8. – mchid Dec 10 '14 at 20:03
  • @mchid I know what the issue is, but I want all his info pasted here for future readers. The system updated the frglx driver to a new version, but the old card doesn't support the new driver. – eyoung100 Dec 10 '14 at 20:07
  • I'll try tommorrow, thanks to both of you. Have to sleep now. – David Dec 10 '14 at 21:13
  • I added what you need to do, it just took awhile to write up. What I told @mchild was reversed. The update updated the kernel, and the old frglx driver doesn't support kernels newer than 3.4.0 – eyoung100 Dec 10 '14 at 22:07
1

Perform the following:

  1. Ctrl + Alt + F3.
  2. Login as your user.
  3. sudo service lightdm stop
  4. startx

Please post the results in your original question. I'll update this answer depending on your output.

Update

As per your comments, now that we've verified your terminal is working we need to install some tools, you may already have these:

  1. sudo apt-get install lshw pciutils nano

Now that we have the tools, post the output of lshw -class display and nano -w /var/log/XOrg.0.log


Update 2

Knowing your Laptop model is a Compaq 615 AMD Athlon X2 Dual Core QL-66 leads me to the official tech spec document, and the following Linux Mint Post:

ATI Mobility Radeon HD 3200 Proprietary Driver for Linux Mint 12

The big red note on that link is what you're experiencing.

Explanation

During the distribution upgrade process your kernel was updated to a newer kernel. Doing so, the upgrade process was unable to use the default radeon driver for your cards, because you had the frglx driver installed. Since your old driver is not compatible with the newer kernel, we have 2 options:

  1. Downgrade to the kernel your frglx driver works with, or
  2. Replace the frglx driver with the default driver and then manually install the older frglx driver.

I personally prefer option 2. So without further ado, I present the


Resolution

  1. From the Command Prompt, issue a:
    sudo apt-get remove --purge xorg-driver-fglrx fglrx* sudo apt-get install --reinstall libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64 libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 xserver-xorg-core
    sudo dpkg-reconfigure xserver-xorg
  2. sudo reboot

This should get lightdm started so you have a GUI, because we need a browser to go to the Legacy AMD Driver Download Page and Download Legacy Version 13.1 for ATI Radeon Series 3xxx. If something failed, and you have no GUI, issue: sudo apt-get install wget && wget http://www2.ati.com/drivers/legacy/amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.zip

Save this for later, as this driver only works for kernels where the version is <= 3.4.0. Since the Ubuntu Kernel is now >= 3.13.0, we will run into the same issue again. This leaves us 2 options:

  1. Manually Download the last available release of the 3.4 Kernel for Ubuntu Manually. If you choose this option Download and install every .deb file in that directory, along with the patches. Note: Using this option prevents you from upgrading to any kernel above Debian 3.4.105 during system updates! In exchange for a permanently downgraded kernel, you may now install the legacy frglxdriverby unzipping the file above. Be sure to use chmod +x on the extracted file.

  2. Install the in-kernel Radeon Driver. This was done in step 1 of the Resolution Section. You can now delete /etc/X11/xorg.conf if you still have one. In exchange for the in-kernel driver, you can continue upgrading to newer kernels as they come out.


References

X Troubleshooting - Ubuntu Wiki - Purging frglx
The definitive guide to proprietary AMD graphics drivers
Ubuntu Wiki - Radeon Driver

  • Thank you! I tried those commands and got a black screen with fast moving text then just a blank screen. I pressed ctl + alt F3 again and then saw a black screen with a lot of text. At the bottom of the page: Warning type "ONE_LEVEL" has 1 lines , but <RALT> has 2 symbols. I tried to log in again but no luck. – David Dec 8 '14 at 21:48
  • Did X Start, after you typed startx? What happened after X started, i.e. what did you see etc? – eyoung100 Dec 8 '14 at 21:52
  • I just saw a lot of text on a black screen scroll down the page very fast and then I got a blank screen. I think that startx started but I am not sure how to know for sure. – David Dec 8 '14 at 21:55
  • Please read this post as I need to examine the log. I also need the laptop model. I have a hunch... – eyoung100 Dec 9 '14 at 20:26
  • Now I got the log files to show up. Do you want to see the whole log? It is 721 lines long. Also, do you want to see Xorg.0.log or Xorg.1.log? Compaq 615 AMD Athlon X2 Dual Core QL-66 I think I have a Radeon 3200 graphics card. – David Dec 10 '14 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.