3

I have been trying to get VirtualBox to enable my USB devices to attach them to the guest OS. However, when trying to attach them while the guest is running all devices are greyed out. Also device filters are not working.

I am pretty sure that this is a rights problem because it works perfectly when starting VirtualBox as root.

Here is my current setup:

  • Host OS: Ubuntu 14.04.1 (64bit)
  • Guest OS: Windows 7 (64bit)
  • VirtualBox 4.3.20 r96996
  • Guest additions are installed
  • Package was downloaded from virtualbox.org

And this is what I tried so far:

Slowly, I am running out of ideas. Most other posts I read about this problem were solved by adding the user to the vboxusers group. However, this did not fix it for me.

I think it might be possible that whatever resource needs to be accessed to handle USB devices is for some reason not accessible for the vboxusers group. I do not know which resource this is so I am unable to check.

Could you point me in the right direction to investigate this further?

  • Did you install the virtual box extension pack (This is not the same as the guest additions) – Charles Green Dec 8 '14 at 22:14
  • You should try to run VirtualBox as root and check if usb are enabled to it. – Javier Rivera Dec 10 '14 at 7:39
  • @JavierRivera As stated in the question, it works when I run VB as root. – Chris Dec 10 '14 at 7:43
  • @Chris It just so happens that I have the same exact problem, using the same configuration settings you had. Did you by any chance find a solution to this issue? Would appreciate it if you shared how you resolved this---if you did that is. – lightonphiri Dec 29 '14 at 21:00
  • @lightonphiri Sorry, problem still persists. – Chris Dec 31 '14 at 15:04
4

I had the same problem as you. The group virtualboxusers and so on were correct.

After some search, it turns out that the kernel module did not correspond to the right version of my kernel (3.13.0-65-generic) and to my version of virtualbox (4.3).

The command

sudo dpkg-reconfigure virtualbox-4.3

solved my problem.

Hope it will help you if the question is still problem still persists.

  • Thanks, the problem went away in the mean time. I also did some VirtualBox updates in that time so it is perfectly possible that this was the issue. – Chris Oct 1 '15 at 7:19
  • I'm fairly certain that I had this issue because I had installed VBox from the repos and then after the fact, I went back and installed from the VBox provided package. With them both installed, I uninstalled (with a purge) the repo version. This apparently removed all kinds of settings (particularly the vboxusers group and permissions) which were still needed for the version from the VBox website. The command above put everything back in place! – b_laoshi Sep 17 '18 at 23:49
1

I'm not sure if this will work, but these are the files owned by vbosusers on my machine, where USB is working right under Virtual Box.

sudo find / -group vboxusers
/dev/vboxusb
/dev/vboxusb/002
/dev/vboxusb/002/003
/dev/vboxusb/001
/dev/vboxusb/001/004

In another machine it looks like this

sudo find / -group vboxusers
/dev/vboxusb

So it looks like only ownership of /dev/vboxusb matters.

Hope that it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.