1

I try to use MarcEdit 6. If I use its tool "Z39.50/SRU Client" to search for any book in any offered library-database it doesn't work and I get the message

"Exception Information: Message: yaz4_64.dll
Source: Zoom.Net.YazSharp
Stack Trace: [...very long text...]"

MarcEdit 6 needs YAZ 5. I installed yaz 4.2.30-2.1build1 which is the only version offered in Ubuntu Software Center - neither is there a version 5 nor any possibility to upgrade. Without knowing what I was doing I also did what is recommended but I'm not sure if I did everything right and if I didn't, where I made a mistake. Maybe somebody can help me with this very specific question.

In the linux_install.txt file of MarcEdit 6 there is recommended:

d) Yaz.Sharp.dll.config -- ensure that the dllmap points to the correct version of the shared libyaz object.

I have no idea what this means.

During the installation of MarcEdit 6 I did nothing exceptional (I unzipped the downloaded file, installed "mono" and executed MarcEditor via the terminal). During the installation of YAZ I first manipulated my sources.list file as recommended in the above README link and finally just got YAZ via the Software Center).

UPDATE: I installed libyaz 5 (sudo apt-get install libyaz5-dev) and it's still the same problem when searching with the Z39.50 client.

I now also changed Yaz.Sharp.dll.config to version 5 (instead of before: dll="yaz3.dll"):

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
   <dllmap dll="yaz5.dll" target="libyaz.so" />
</configuration>
  • From what I can see MarcEdit is a Windows program, and thus includes its own copy of the yaz library (the yaz4_64.dll). However, it appears to be crashing for you when you try to do this. You need to report this as a bug to the MarcEdit developers. It seems to have nothing to do with Ubuntu. – dobey Dec 8 '14 at 19:54
  • @dobey I see a Linux download on their site (sorry I don't have a link, slow tablet here). The appearance of a dll is confusing however. mischa004: please edit your question to include more information about what version of marcedit you are using and how you installed it. Thanks. – Seth Dec 8 '14 at 19:59
  • Just before I go into details this short question: maybe it has got to do with the following information from the linux_install.txt-file? It says:"Yaz.Sharp.dll.config -- ensure that the dllmap points to the correct version of the shared libyaz object." I absolutely don't understand what this is saying, sorry. – Michael Käfer Dec 8 '14 at 20:03
  • @Seth Yes, it is a proprietary Windows application written in C#. It appears to be trying to use Windows DLLs. Maybe it's not meant to, but seems that asking support from the developers directly is appropriate, as it is a proprietary application. – dobey Dec 8 '14 at 20:09
  • @dobey Yes, asking the developer is appropriate, but I do not believe that is a good reason to shut them down here. – Seth Dec 8 '14 at 20:14
1

I don't know if you will see this now, but the config you want to use is:

<?xml version="1.0" encoding="utf-8" ?>

<configuration>
    <dllmap dll="yaz4_64.dll" target="libyaz.so.5" />
</configuration>

This works for me.

|improve this answer|||||
  • Note for version 6 ~ November 2017. The file to edit is now Zoom.Net.YazSharp.dll – Jack Nov 1 '17 at 8:49
0

It works, the developer told me to change in the Zoom.Net.YazSharp.dll.config file the following:

dll="yaz4_64.dll" target="libyaz.so"

But the following problem occured and the developer has no solution (he wrote: "that’s not a file referenced in MarcEdit")

Exception Information:
Message: winhttp.dll
Source: mebatch
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.