-1

I am a new Linux user, and I'm currently using the latest version of Lubuntu. I want to create a virtual machine with VMware because in VirtualBox I am not able to use DirectX in Windows XP. Even after installing it on the operating system, it says it has no DirectX installed.

Because I prefer to use VMware (since I downloaded VMware for Windows) I tried to use it in Ubuntu, but VMware won't work as it does in Windows, so I downloaded VMware version 8, but I am not able to use it because of the following error:

Before you can run VMware, several modules must be compiled and loaded into the running kernel.
Kernel Header 3.16.0-25-generic
Kernel headers for version 3.16.0-25-generic were not found. 
If you installed them in a non-default path you can specify the path below.   
Otherwise refer to your distribution's documentation for installation instructions and click Refresh to search again in default locations.
  • Please Translate in ENGLISH .. – Ashu_FalcoN Dec 9 '14 at 15:05
  • You need to install the development headers for your kernel. That will permit this to work. HOWEVER, Shared Folders will not work due to a bug in vmware tools as a result of newer kernels. – Thomas Ward Dec 9 '14 at 17:19
0

You'll need to install the headers for your version of the kernel.

In this case, you're on Utopic (based on your kernel version in the error), so you'll need the linux-headers-3.16.0-25-generic package. This will install the headers: sudo apt-get install linux-headers-3.16.0-25-generic

  • Desculpe colocar mais de um comentário, porém não coube tudo em um comentário. – Camilo Gusmão Dec 10 '14 at 23:07
  • sudo apt-get install linux-headers-3.16.0-25-generic Lendo listas de pacotes... Pronto Construindo árvore de dependências Lendo informação de estado... Pronto linux-headers-3.16.0-25-generic já é a versão mais nova. Os seguintes pacotes foram instalados automaticamente e já não são necessários: ca-certificates-java default-jre-headless kde-l10n-engb kde-l10n-pt – Camilo Gusmão Dec 10 '14 at 23:08
  • kde-l10n-ptbr lib32gcc1 libc6-i386 libgconf2-4 libgsoap5 libvncserver0 libwxbase2.8-0 libwxgtk-media2.8-0 libwxgtk2.8-0 openjdk-7-jre-headless python-wxgtk2.8 python-wxversion tzdata-java Utilize 'apt-get autoremove' para os remover. 0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 10 não atualizados. – Camilo Gusmão Dec 10 '14 at 23:09
  • @CamiloGusmão please use ENGLISH - This is a primarily English site and I do not have the ability to read non-English. – Thomas Ward Dec 10 '14 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.