1

With 14.04 I installed a network printer, hosted on a different windows PC. Everything worked fine, but after upgrading to 14.10 I get the error that I can't print. When trying to open the properties of said printer it said

There was a problem connecting to the CUPS server

So I wanted to reinstall the printer, and what I did before was

  1. Click Windows Printer via SAMBA
  2. Click "Browse..." to browse the samba network for the printer
  3. Select the printer

Now in 14.10 I get stuck at the second step as the "Browse..." button is disabled. How do I enable it again?

enter image description here

0

By filling in the name or IP address of the Windows machine? ;-)

  • 2
    Thats how I hacked the connection now, but it was so much easier through the samba browse dialog. – Peter Raeves Dec 9 '14 at 3:04
  • Is the workgroup = YourWindowsWorkgroup in your /etc/samba/smb.conf file configured correctly? maybe the upgrade to 14.10 broke that somehow... (I'm still on 14.04.1 and only use LTS versions...) – Fabby Dec 9 '14 at 19:30
  • What do you mean with "YourWorkgroup", because I have two workgroups in my network. Before I could press the browse and then I could see the two workgroups and I could browse them separately. – Peter Raeves Dec 9 '14 at 19:48
  • Mmmh.... Try setting it to the empty string then! (Now I'm just grasping at straws, but it might just work... Please report back after you've tried. – Fabby Dec 9 '14 at 20:40
  • 1
    I upvoted instead, since it is not a direct answer to the posed question, but it is indeed a work-around that worked for me. It should be mentioned though that although the machine is usually running all the time, to be safe I made my router reserve the specific IP address for the printer PC, since the router is used by other devices as well. If due to a restart or a shut-down, the IP was changed I wouldn't be able to print through the installed printer any more as the IP was hard-coded. (I think this happened when I was fixing the lighting in that room while my PC was updating to Ub14.10) – Peter Raeves Dec 10 '14 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.