2

I have run juju -v --debug bootstrap -e auits and the last thing juju returns is

Logging to /var/log/cloud-init-output.log on remote host
Running apt-get update
Running apt-get upgrade
Installing package: git
Installing package: curl
Installing package: cpu-checker
Installing package: bridge-utils
Installing package: rsyslog-gnutls
Fetching tools: curl -sSfw 'tools from %{url_effective} downloaded: HTTP %{http_code}; time %{time_total}s; size %{size_download} bytes; speed %{speed_download} bytes/s ' --retry 10 -o $bin/tools.tar.gz 'https://streams.canonical.com/juju/tools/releases/juju-1.20.13-trusty-amd64.tgz'
Bootstrapping Juju machine agent
Starting Juju machine agent (jujud-machine-0)
2014-12-08 13:34:37 INFO juju.cmd supercommand.go:329 command finished

But the maas deployment fails and leaves the machine in a "Failed deployment" state. It looks like the bootstrap worked, why the failed deployment? Juju status says it is bootstrapped.

Full pastbin of log is at http://pastebin.com/3LDxnQyy

closed as off-topic by Zanna, user364819, Anwar, waltinator, Eric Carvalho May 20 '17 at 19:49

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Zanna, Community, Anwar, waltinator, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Would you accept you own answer as that what worked for you. It will others with same issue find the solution. – user.dz Jun 13 '16 at 4:45
0

I had a problem with the DNS forwarder on my MaaS server which was probably the cause of this. An upgrade to an updated MaaS pointed out the problem to me. After fixing it machines seem to be deploying better.

  • could you elaborate on how you fixed it? – Zanna Apr 7 '17 at 6:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.