6

Doing some trial and error :( on a linode.

I've tried tightvnc but get a grey screen with the identical setup I used to use with 12.04. I ran with 12.04 and tightvnc successfully for about 2 years.

I have an outstanding bug reported for x2go and 12.04 so I'm hesitant to use it with 14.04. The bug is unacceptably slow performance after a few hours of use. This is x2go bug # 465.

I considered nomachine's free edition but their website says that "the free NoMachine 4 is designed to work the same across Windows, Mac and Linux and give users access to the physical desktop of the remote computer. If you need to create virtual desktops on demand, want to limit the logins to SSH, or are using NIS, Kerberos or other enterprise server functionalities, you need one of the NoMachine Enterprise server products". If my understanding is correct, a cloud server from linode has no physical desktop provided to the customer so nomachine is recommending the paid-for product.

I tried x11vnc but have not succeeded and I have an unanswered problem for this method. My question for x11vnc and 14.04. x11vnc might also need a physical display.

  • Is it a requirement that you run Unity? Or is Xfce/Gnome fallback an option? – Tobias Dec 12 '14 at 19:07
  • I don't need Unity but I do need a headless graphical desktop. – H2ONaCl Dec 13 '14 at 16:46
  • You could try: xrdp.org . I'm not sure why any of them are causing trouble though. They should all be fine. – krowe Dec 16 '14 at 0:18
4

Below method works for me.

Install desktop with minimal packages.

sudo apt-get install --no-install-recommends ubuntu-desktop

Install few gnome packages to load VNC properly.

sudo apt-get install gnome-panel gnome-settings-daemon metacity nautilus gnome-terminal

Install vnc4server

sudo apt-get install vnc4server

Open /usr/bin/vncserver

Find "# exec /etc/X11/xinit/xinitrc\n\n". line and add these lines below

      "# exec /etc/X11/xinit/xinitrc\n\n".
       "gnome-panel &\n".
       "gnome-settings-daemon &\n".
       "metacity &\n".
       "nautilus &\n".
       "gnome-terminal &\n".

Start vncserver

vncserver

Afetr starting session , you could access VNC with your IP and session ( 12.34.56.78:1 ) enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.