4

I have a Samsung m2020w printer. I have succeeded in downloading the printer drivers and can use the printer with a USB cable. However, I am unable to use the wireless connection. The difficulty is that I can't connect the printer to the wifi network (as this needs to be done via a PC).

I've tried using the installation disk via Wine but at the point that I am asked to temporarily connect the printer to the computer with a USB lead I get the message "The printer is not found" even though I can print pages (proving that the printer is connected).

Any ideas?

1

You will need a little networking knowhow to get your Samsung setup wirelessly. It doesn t appear the control panel gives you the option of lower case letters. I first wire connected the printer to an open port on the router. When the connection was established I printed out the network settings in order to obtain the printer s wired IP address. I opened up my browser and typed in the IP address (eg. 192.168.1.x) which connected me to the network interface on the Samsung printer. From there I clicked Network > Wireless and was able to find my SSID and enter in my password (which included upper case, lower case, and numbers.) I removed the wired cable from the printer and router and the printer was able to establish a wireles connection.

Source(s): https://answers.yahoo.com/question/index?qid=20111020020118AAsID9Q

1
  • I dont think this printer has an ethernet cable connection.
    – rodvlopes
    Jul 7 '16 at 3:38
1

I've installed the printer in Wireless mode with this procedure:

  1. Install the printer drivers on your Ubuntu PC. The drivers can be found here https://support.hp.com/us-en/drivers/selfservice/samsung-xpress-sl-m2020-laser-printer-series/16462592/model/16462596

  2. You get a file named uld_V1.00.39_01.17.tar.gz or something similar depending on the version of the driver.

  3. Open a terminal window and run the following commands:

    # cd Downloads
    # tar -xvzf uld_V1.00.39_01.17.tar.gz
    # cd uld
    # sudo ./install-printer.sh
    

    and follow the installation procedure.

  4. Now, on your Android Mobile Phone install the App "Samsung Mobile Print" from Google Play https://play.google.com/store/apps/details?id=com.sec.print.mobileprint

  5. Setup the printer using your mobile phone. Connect the printer to your WiFi Network (the same wifi network your linux PC is connected).

  6. Once connected to your wifi your printer should appear and install automatically. In my case UBUNTU 18.04 with Gnome Shell Desktop.

  7. If not no problem: go to settings - printers - find/install new printer. The printer should appear in the list of avaiable printers. Select and install.

1
  • For me, the mobile app hangs while "waiting for printer", even though I press the WPS button. My printer might be defective. Earlier, I was able to print to the printer via USB, which suddenly stopped working after nearly 3 years.
    – Cerin
    Nov 26 '18 at 17:07
0

I've successfully connected my printer to my router clicking in the printer WPS button and in the button in the router control panel. Unfortunately it was necessary to repeat the process every time I wanted to use it. After connecting a Windows machine and configuring through USB it looks like the printer reconnects automaticaly.

If you have an Android phone, you also can configure it using the Samsung Mobile Print app.

2
  • Is it really possible to configure it using Android app? I've not found any Wi-Fi settings when you connect to the printer using Wi-Fi direct
    – tomrozb
    Oct 19 '18 at 3:21
  • @tomrozb use the linked app. But I confess that the need to repeat the process everytime made me quit using it. Nowadays I just send any doc by email.
    – neves
    Oct 19 '18 at 15:50
0

Set the printer up using the USB link and configure cloud print without accessing the printer. Use Samsung printer diagnostics to connect to the printer via the USB. This has a wireless set up where you can enter the router password. I have now printed from my phone and from the PC. You do end up with several Samsung printers so it is important to select the network one. In my case it started with SEC

0

Had the same problem. Solved it by turning on WPS on Wi-Fi router. After printer connected to my Wi-Fi i was able to see it in Network list and connect it with ipp settings. Thats all :) If you have any questions please don't hesitate to ask

-2

I wrote the instructions in ubuntu forums:

http://ubuntuforums.org/showthread.php?t=2263245

2
  • Those instructions do not work. Even after connecting to the printer's wireless network, I'm unable to access any webpage at "my IP". Although Samsung's own documentation is equally useless.
    – Cerin
    Nov 25 '15 at 22:18
  • If your own IP doesen't work, try the printer's.
    – lenooh
    Nov 28 '15 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.