1

I'm in a situation similar to the one described in this post ALERT! /dev/disk/by-uuid/xxxxxxxxx does not exist. Dropping to a shell

I have 2 internal hard drives. The original Ubuntu 14.04 LTS installation booted from /dev/sdb2, using /dev/sdb1 as swap.

I tried a clean installation on /dev/sda2 from an USB stick and booting it gave me the same issue.

Booting from /dev/sda3 (the original windows 7 recovery partition) works perfectly.

Booting from the USB stick, the filesystems on /dev/sda2 and /dev/sdb2 look OK.

Obviously I tried the suggested procedures on /dev/sdb2 and on /dev/sda2 but with no result.

  • So what does your fstab contain now? UID or sdX? – Fabby Dec 9 '14 at 1:42
  • 1
    UUID anyway i asked on ubuntuforums also, and i got a suggestion to run grub-install instead of updating, and strangely that did the trick, the problem is solved – ramon7108 Dec 9 '14 at 8:49
1

I tried the procedure mentioned here but nothing changed. I then got a suggestion of running grub-install instead of update-grub after update-initramfs and that mysteriously did the trick.

  • Please use the edit link on your question to add additional information. The Post Answer button should be used only for complete answers to the question. – Luís de Sousa Dec 9 '14 at 9:27
  • @LuísdeSousa: that's what he did: he got an answer on Ubuntuforums and then posted it here! ;-) – Fabby Dec 9 '14 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.