0

The Ubuntu backup system was using up too much of my disk space, so I decided to start fresch, and manually remove all existing backup files. But now every time I start the backup process (either by clicking the 'Back Up Now...' button, or by using 'deja-dup --backup' from the CLI, I get a popup window containing this message:

Specified archive directory '/home/[me]/.cache/deja-dup/7b5f5b35d423174917aee4c3a7052081' does not exist, or is not a directory

$ ls -las /home/[me]/.cache/deja-dup/
total 8
4 drwxr-xr-x 2 root root 4096 Dec  8 10:46 .
4 drwxrwxr-x 3 arne arne 4096 Dec  8 09:55 ..

How do I reset deja-dup? Where is the '7b5f5b35d423174917aee4c3a7052081' information saved?

[extra info]

Perhaps I should note that

~/.cache/deja-dup 

is symlinked to a folder on a extra hard drive (/dev/sdb1, ext3) mounted in /media/WD1TB.

3 Answers 3

1

Turns out

~/.cache/deja-dup

wasn't writable.

But now I get

Could not restore ‘~/.cache/deja-dup/metadata’: File not found in backup'...

see my new post:

"Backup Failed": Could not restore ‘~/.cache/deja-dup/metadata’: File not found in backup

0

You should have used the UI to do that, but now that you are in this situation, a

sudo apt-get remove --purge deja-dup

and

sudo apt-get install deja-dup

should fully reset deja-dup...

However, now that you're uninstalling deja-dup anyway, you might have a look at "back-in-time" as well... ;-)

3
  • That seems overly complicated, removing and reinstalling... but fine.
    – klokop
    Commented Dec 11, 2014 at 18:44
  • I can also tell you to install gtkorphan but as you broke things already, the above is the safe option... :P ;-) Oh, and if it works, please don't forget to accept my answer and if you really like it, upvote as well! :)
    – Fabby
    Commented Dec 11, 2014 at 18:46
  • Nope. Didn't work. Still getting the same error.
    – klokop
    Commented Dec 11, 2014 at 19:12
0

I just deleted /home/<me>/.cache/deja-dup and /home/<me>/.cache/duplicity and that seemed to reset things. Now it is going ahead and made a new backup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .