I'm trying to crack an wifi, but when i type sudo airmon-ng start wlan0 it shows this:

Found 4 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
463 avahi-daemon
475 avahi-daemon
683 NetworkManager
756 wpa_supplicant

Interface   Chipset     Driver

wlan0       Broadcom    wl - [phy0]mon0: ERROR while getting interface flags: No such device

                (monitor mode enabled on mon0)

Then, when I type sudo airodump-ng mon0 for the list with available BSSID it shows this:

sudo airodump-ng mon0
Interface mon0: 
ioctl(SIOCGIFINDEX) failed: No such device

What can cause this?

This is my wconfig:

wlan0     IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

ppp0      no wireless extensions.

lo        no wireless extensions.

My OS is 14.10. My Laptop is Aspire 5745G.

  • solve this by any chance? i am having the same issue and i kept coming across a blocker of some sort with the options presented in the answer below – greenhouse Jun 13 '15 at 4:45

The first error seems to indicated that Network Manager is already using wlan0 (in addition to wpa_supplicant and the other processes).

You don't have an interface called mon0, so that's why you get the second error.

You should be able to use aircrack if you don't use wifi via Network Manager (you can try stopping network manager and then running the command). Note that if Network Manager is not running, you have to handle the wifi configuration yourself.

You could also try adding a virtual interface to your wireless phy with iw. To do this, look at the output of "iw phy". My wifi card is phy0, so:

"sudo iw phy phy0 interface add mon0 type monitor"

Then retry the second command.

You can get an idea of what your card supports with "iw phy phy0 info". Again, replace phy0 with the correct argument. Check that it supports monitor mode if you have problems adding a monitor interface.

I noticed you have a broadcom card, so monitor should be supported. You can check your wifi card support here http://wireless.kernel.org/en/users/Drivers

type this before use aircrack-ng:

sudo ifconfig <interface(wlan0)> down

then use the aircrack-ng if not work try this:

sudo airmon-ng check kill

then airmon-ng start.............

Was seeing the same error running precompiled binaries on Raspian and ended up building from source to get past it.

  • While this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Kevin Bowen Aug 9 '16 at 20:18
  • Thanks for the feedback and I see your point. But anything more detailed is likely to vary by system or configuration, and over time, and would likely cause more frustration than it would benefit the audience. – Josh Habdas Aug 10 '16 at 23:11

This conflicting behavior comes from network manager. If you don't want to use sudo airmon-ng check kill (which totally stop network manager) you can add an exception for your mon0 interface as explained here: aircrack-ng : airmon-ng stop working after updating to 15.04 ( ioctl(SIOCSIWMODE) failed: Device or resource busy )

1.Open network manger configuration file with root privileges

sudo gedit /etc/NetworkManager/NetworkManager.conf

2.Add the following lines at the end of your file to create an exception for your mode monitor interfaces.

[keyfile]
unmanaged-devices=interface-name:mon*;

Once you saved the changes effects are immediate and airmon-ng will be able to handle properly the interface Be aware that you are using an outdated version of aircrack-ng (the one from ubuntu repositories I guess) I strongly suggest you to install a more recent version (in this case the mode monitor interface will be called wlan0mon and not mon0 anymore) Go to aircrack-ng website to download the latest stable release (Aircrack-ng 1.2 RC 4 ): aircrack-ng website

When you type sudo airodump-ng mon0, it appears

sudo airodump-ng mon0
Interface mon0:
ioctl(SIOCGIFINDEX) failed: No such device

cause you don't have that interface, but you have

Interface   Chipset     Driver

wlan0       Broadcom    wl - [phy0]mon0: ERROR while getting interface flags: No such device

                (monitor mode enabled on mon0)

try using sudo airodump-ng wlan0.

By The Way your output said

wl - [phy0]mon0: ERROR while getting interface flags: No such device

cause you have aircrack-ng very old version, Make sure you installed the latest version of aircrack-ng package.

Your not alone, another Question have same issue with yours.

Hope this helps.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.