0

Issue

Upon boot, wireless connects to my Asus RT N66U correctly. Speed tests indicate 50 Mbps down and 40 Mbps up. This is expected.

Shortly after boot, the wireless will drop out, reconnect, and then be horribly slow / unstable / non-responsive. Speed tests then indicate time outs or < 5 Mbps down.

System

I'm on Ubuntu 14.04.

lsusb reports my WiFi device as:

Bus 003 Device 005: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

lshw -C network shows:

*-network
       description: Wireless interface
       physical id: 1
       bus info: usb@3:4
       logical name: wlan0
       serial: 2c:d0:5a:e2:05:e3
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=ath9k_htc driverversion=3.13.0-40-generic firmware=1.3 ip=192.168.1.140 link=yes multicast=yes wireless=IEEE 802.11bgn

What I've Tried

The following seems to have made no difference:

echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

echo "options ath9k_htc nohwcrypt=1" > /etc/modprobe.d/ath9k_htc.conf

0

I'm currently running 12.04 and will be upgrading to 14.04. My wifi has never caused me problems until I tried to connect to an Asus RT-AC68U gigabit router. Then suddenly, the connection kept dropping, etc. Same problem noted in this thread. But on my older Netgear router at home, the connection is always stable. The fix that worked for me was to purchase an Asus USB-N53 wifi adapter. My onboard wifi used the Broadcom driver, and there seems to be a problem with these drivers and the newer routers. Reinstalling the driver and trying the other remedies listed on various forum threads did not work. The other nice thing about the USB adapter is that even though it is not a perfect solution (the connection still can drop sometimes, although rarely), it can easily be power cycled by unplugging then replugging in (versus doing "services networking restart" or rebooting).

  • Funny thing about this...I purchased a USB adapter to solve my issue as well. – Justin Skiles Dec 11 '14 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.