1

When I installed KDE on Ubuntu 14.10, it messed up some of the Unity settings like the text size and theme colors. I finally managed to completely remove it from my computer, and the text is back to normal, but my theme colors are still off.

Only the Ambiance theme is different, specifically, the menu bar drop-down text is a dark grey. I've tried a few different methods of fixing it, none of which worked. I created another user account to diagnose the problem and the Ambiance theme is normal in the other account. How can I get the Ambiance theme back to it's default? (I've tried reinstalling light-themes.)

Similar to this question, except the solution doesn't work for me.

This is how it looks in the admin account:
How it is.

This is how it looks in the new account and how it should look:
How it should be

EDIT: I later installed Wallch and it messed up the icons to always be the gnome icons, regardless of what theme or icons I chose with Unity Tweak Tool. This was also fixed with the solution described below. I don't actually know if it was Wallch that caused the problem.

5

Finally figured it out!!! Somehow, KDE must've modified my user's gtk3 settings.

To fix it, just go to /home/[USERNAME]/.config/gtk-3.0 and delete settings.ini. Ubuntu will freak out and try to report a bunch of errors, but restart your system and it will all be back to normal.

This is what my settings.ini file looked like:

[Settings]
gtk-font-name=Ubuntu 9
gtk-theme-name=oxygen-gtk
gtk-icon-theme-name= oxygen
gtk-fallback-icon-theme=gnome
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-menu-images=1
gtk-button-images=1
  • My file was identical and I also switched from KDE/Kubuntu. After moving it and logging out/in, the file was still gone but the theme looked correct again. – cs01 Mar 16 '16 at 17:48
2

if deleted your themes, install them by

sudo apt-get install light-themes

Now go to Go to System Settings -> Appearance and changed your theme to Ambiance (default)

  • Life saver! I had somehow messed up my default themes so there were no borders around any controls - tabs, buttons, checkboxes just "didn't render", and text selection didn't render either. Narrowed it down to a theme issue by switching to high-contrast (which looked fine), and finally found this to fix my default themes! – Krease Feb 14 '18 at 0:26
-1

$ unity --reset

This option allows the user to reset profile parameters in compiz and restart the Unity shell with default settings.

  • 1
    ERROR: the reset option is now deprecated – Prime624 Dec 8 '14 at 2:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.