37

I've just installed Ubuntu 14.10 and I copied over my .remmina folder from my old 14.04 install and all my connections are there however when I connect to remote windows computer through rdp which is displayed fullscreen (which I want) I don't get the grey toolbar when I move the mouse to the top of the screen. Using the keyboard shortcut F4 to disconnect does not disconnect the session so the only way I can get out if it is to kill it through the system monitor.

Any ideas how to resolve this as it is extremely frustrating?

5 Answers 5

69

To exit full screen mode in Remmina, press the right hand side Ctrl key and f together.

3
  • 18
    Confusingly enough for me it only worked with the ctrl key on the right side of the keyboard. Jul 8, 2015 at 14:18
  • I believe that the host key assignment determines which control key is used to activate the keyboard shortcuts. My host key was Control_R and changed it to Control_L and toggling full screen works again but then using left ctrl + c no longer works on the remote machine as this has been taken over as the host assignment key. It's a win/lose situation I guess. Feb 16, 2016 at 11:37
  • It is easy to change it to the left-hand Ctrl key - see my answer below.
    – SDsolar
    Jan 16, 2018 at 19:21
3

It's a bug, see https://github.com/FreeRDP/Remmina/wiki/Remmina-Usage-FAQ point 3

It's apparently fixed but not in the version that ships with yakkety.

As a workaround you can use HostKey+F (HostKey can be set in Edit > Settings > Keyboard and by default is set to the right Ctrl key). HostKey+F toggles the Fullscreen Mode and you can go back to your normal Desktop if the remmina-window is not in fullscreen.

0
1

Ok I can disconnect by using CTRL_R + F4 however I cannot get T for show/hide toolbar to work no matter what I key combo I use with it.

I've renamed the .remmina folder and and restarted remmina and recreated one of my connections and I get the same issue so I guess it's a bug (as they still have the reference to the toolbar in shortcuts so doesn't look like they've removed it).

1

You are correct, even the 1.2 release of Remmina doesn't properly show the tabs or exit in Ubuntu.

I found that if I use the Right Ctrl+ I can switch between remote sessions, and that in a Windows Server 2012 session I can bring up the menu to power off and a small menu pops up labeled 'disconnect.' Only in that way was I able to shut down the session.

0

I'm running Ubuntu 16.04 LTS with remmina.

You can always use Alt + Tab to get back to your desktop and to the remmina control screen. Just like with Windows.

When you get to the control screen you can use Edit -> Preferences -> Keyboard.

The top option is the "Host key"

Click on the box that says "Control_R" and then it will prompt you to press another key.

In my case, my mini-keyboard does not have a Right-hand Ctrl key, so I press the Left one.

It then displays "Control_L" and I click on "Close" then click on the maximized window which is underneath.

You can also use Alt + Tab to get back to the full-screen session.

Voila, the left-hand Ctrl + f works to un-maximize it and bring back the toolbars on top.

Not the answer you're looking for? Browse other questions tagged or ask your own question.