2

I recently set up a new HTPC on Ubuntu 14.04 LTS and the only option for audio (that works) is HDMI / DisplayPort but there is no dropdown box for 5.1 surround sound. I did a lot of digging and after killing all audio once and reinstalling Ubuntu I feel like I can talk about it intelligently, but I don't know a solution.

For the time I deactivated my onboard sound to limit the amount of audio stuff since it's going through hdmi and not onboard (I know it still works as a speaker-test c6 works will all parts of the 5.1 system).

Here's my "aplay -L":

null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
default
Playback/recording through the PulseAudio sound server
hdmi:CARD=HDMI,DEV=0
HDA ATI HDMI, HDMI 0
HDMI Audio Output
hdmi:CARD=HDMI,DEV=1
HDA ATI HDMI, HDMI 1
HDMI Audio Output
dmix:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct sample mixing device
dmix:CARD=HDMI,DEV=7
HDA ATI HDMI, HDMI 1
Direct sample mixing device
dsnoop:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct sample snooping device
dsnoop:CARD=HDMI,DEV=7
HDA ATI HDMI, HDMI 1
Direct sample snooping device
hw:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct hardware device without any conversions
hw:CARD=HDMI,DEV=7
HDA ATI HDMI, HDMI 1
Direct hardware device without any conversions
plughw:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Hardware device with all software conversions
plughw:CARD=HDMI,DEV=7
HDA ATI HDMI, HDMI 1
Hardware device with all software conversions

"speaker-test -Dhdmi:CARD=HDMI -c6" works great! So why don't I have the option to output to 5.1 surround?

System Specs: Motherboard: ASRock FM2A88X-ITX+

Processor: AMD A6-5400K Trinity APU

  • 1
    Same problem here. I have a Gigabyte GB-BXA8-5545 motherboard with AMDA8-5545M, Trinity, with Radeon 8510G . Was losing hope until I tried your speaker-test and it worked correctly. – foobarbecue Jan 14 '15 at 21:08
  • Not to be a downer but I ended up installing Windows 8 and the sound is great. – SMASH Jan 15 '15 at 20:49
  • 1
    I sort of got mine to work (on Kubuntu 14.10). I used mplayer with the -channels 6 and -ao [device] option, and I played a movie with excellent 5.1. I haven't been able to convince any other programs to use 5.1 yet. – foobarbecue Jan 16 '15 at 16:39
  • Good on you! Add it as an answer and I'll mark it as the correct answer. That's way farther than anyone else has gotten. – SMASH Jan 24 '15 at 17:13
  • Ok. I'm still learning how things work in the underbelly of the linux sound systems, which is a sort of morass of mystery and dark magic. Ultimately I want to have an MPD server which I can command to play 5.1 music locally and also stream a 2-channel version to the other computers in my house. I'll post an answer once I feel like I actually know what's going on :-) – foobarbecue Jan 24 '15 at 18:00
0

I've had mplayer playing 5.1 .mkv movies and 5.1 .flac music for a while now on my Kubuntu 14.10 system (also worked when it was on 14.04, but I upgraded at some point) and today finally got it to work in VLC. I have a Gigabyte GB-BXA8-5545 motherboard with AMDA8-5545M, Trinity, with Radeon 8510G. My solution is to use ALSA, and then you just have to make sure your player is using the correct device. The settings that worked for me in VLC were:

enter image description here

I did have to close and re-open VLC after changing the settings before it started working.

Part of the reason I had trouble getting this to work is that the device that outputs to HDMI 0 is actually card 0, device 3:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This speaker test worked:

speaker-test -c 6 -r 48000 -D hw:0,3

And mplayer plays 5.1 videos with this:

mplayer -channels 6 -ao alsa:device=hdmi=0 myvideo.mkv

Incidentally, when I play the 5.1 video over HDMI, the receiver I'm using (Yamaha RX-V473) switches to "PCM" mode when I start playing in mplayer, by "DTS" if I play through VLC. Either way, both 5 channels are active. I'm not sure what this means, maybe mplayer is decoding the DTS whereas VLC is passing it through?

Feel free to comment and ask if you'd like more details on my setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.