3

I recently put together a new computer as an HTPC. I've tried a few different flavors of Linux on it before settling on Lubuntu. The only problem? I can't get any sound out from the system whatsoever.

I've tried both Lubuntu 14.10, and Lubuntu 14.04. I was able to get the audio working (albeit crackling) when I had Ubuntu 14.04 and Ubuntu 14.10 installed. However, since both had more processing overhead and more features than I was going to use, I stepped down to Lubuntu.

As the header says, I'm running my audio to my TV via HDMI, but I'm getting absolutely nothing out of it. When I run alsamixer, it identifies my card as "HD-Audio Generic", and my chip as "ATI R6xx HDMI". I know the ID for the device is 0,3, but that doesn't do me much good since I'm not much of a Linux power user.

Does anyone have any ideas to help me out? I've been working on it all week and it's driving me nuts. :/

After a little bit more testing, it appears no audio is working on the system at all. I plugged some headphones in, set the default audio output to the analog jack, and still got nothing. I verified nothing was muted, my sound was turned up to a decent volume... I still have no idea.

1
  • It sounds like it's not outputting sound, more taking in sound (like a mic), Wanderlust's answer is in depth and looks like it should do the trick :) – SomeAmbigiousUserName Dec 9 '14 at 8:59
3

The output option to HDMI was not shown. In pavucontrol, you could set the whole device to

Digital Stereo (HDMI) Output

hdmi output

This might fix it for you.

0
2

I had the very same problem installing Lubuntu on a new media center PC I built recently with an embedded A4-5000. I had to download PulseAudio in order to change the default audio output (if I recall it was trying to do SPDIF) to HDMI out. Why it does not do this automatically I don't know. I also had the crackling noise you mentioned when I finally got my audio working, had me pulling my hair out cause I could not find a solution that worked.

I could not find the sample rates and such to tinker with in the pulseaudio.conf file some people mentioned, so I went in to the software center and downloaded Alsamixergui, Qasconfig, QasHctl, and Qasmixer to see if any of those programs had the necessary audio setting I needed to fiddle with. I couldn't find whatIi was looking for, but after I went into QasHctl and fiddling with the levels, the crackling is almost non-existent when watching Youtube.

Created an account just to reply, hope this helps.

1

Open a terminal and type the following command to install the pulse audio volume control

sudo apt-get update
sudo apt-get install pavucontrol

do a search for the app or execute pavucontrol. This is not the same as the volume control on your panel.

You will have more control over card selection and assigning devices. Also, sometimes unplugging and plugging the HDMI back in automatically toggles it into a working state.

-2

Simply open your video player and set the Video Option Output to HDMI. Bye. Paolo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.