0

I'm trying to get phpmyadmin up on my browser after installing ubuntu server 14.04 which works fine. I can pull up the apache2 website with 10.0.2.15. I installed webmin with not problems, and that works on 10.0.2.15:10000. The problem is phpmyadmin will not come up after installation, I believe it installed fine as not errors were showing upon sudo apt-get install phpmyadmin. I notice that on the browser it has a 404 not found on port 80. Is port 80 blocked in this case? Should I set to NAT with port forwarding? Any idea what I'm doing wrong?

$ ls -l /etc/apache2/conf-available:    
-rw-r--r-- 1 root root 315 Jan 3 2014 charset.conf
-rw-r--r-- 1 root root 127 Aug 11 2014 javascript-common.conf
-rw-r--r-- 1 root root 3224 Jan 3 2014 localized-error-pages.conf
-rw-r--r-- 1 root root 189 Jan 3 2014 other-vhosts-access-log.conf
-rw-r--r-- 1 root root 2190 Jan 3 2014 security.conf
-rw-r--r-- 1 root root 455 Jan 7 2014 serve-cgi-bin.conf

$ ls -l /etc/apache2/conf-enabled    
lrwxrwxrwx 1 root root 30 Dec 6 11:13 charset.conf -> ../conf-available/charset.conf
lrwxrwxrwx 1 root root 40 Dec 6 11:45 javascript-common.conf -> ../conf-available/javascript-common.conf
lrwxrwxrwx 1 root root 44 Dec 6 11:13 localized-error-pages.conf -> ../conf-available/localized-error-pages.conf
lrwxrwxrwx 1 root root 46 Dec 6 11:13 other-vhosts-access-log.conf -> ../conf-available/other-vhosts-access-log.conf
lrwxrwxrwx 1 root root 31 Dec 6 11:13 security.conf -> ../conf-available/security.conf
lrwxrwxrwx 1 root root 36 Dec 6 11:13 serve-cgi-bin.conf -> ../conf-available/serve-cgi-bin.conf
  • A 404 indicates that it was able to connect to the server just fine, but what you requested was not found ("404 Not Found"). Can you post the output of ls -l /etc/apache2/conf-available and ls -l /etc/apache2/conf-enabled by editing your question? – muru Dec 6 '14 at 17:19
  • Is there a way to cut and paste in virtualbox? – Kevin Dec 6 '14 at 18:05
  • If you install virtualbox guest addons, the clipboard is shared. – muru Dec 6 '14 at 18:06
  • This could be that I'm running 14.04 in virtualbox and not 13.04 which is I think what is supposed to be used. Sorry if that is the case. – Kevin Dec 6 '14 at 18:43
1

When you install phpmyadmin, you should be asked which server it should configure web access for:

enter image description here

If you select apache2, as shown in the image, a configuration file is added to conf-available:

 ls -l /etc/apache2/conf-available/
total 20
-rw-r--r-- 1 root root  315 Jan  3  2014 charset.conf
-rw-r--r-- 1 root root 3224 Jan  3  2014 localized-error-pages.conf
-rw-r--r-- 1 root root  189 Jan  3  2014 other-vhosts-access-log.conf
lrwxrwxrwx 1 root root   28 Dec  7 00:14 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
-rw-r--r-- 1 root root 2190 Jan  3  2014 security.conf
-rw-r--r-- 1 root root  455 Jan  7  2014 serve-cgi-bin.conf

Since this file does not exist for your, I suggest you run:

sudo dpkg-reconfigure phpmyadmin

And select apache2 when prompted.

  • Thanks, that helped! I thought I had selected apache2 just by highlighting that option and pressing enter, but it is important to set the asterisk with spacebar. Cheers! – georgebrindeiro Jan 24 '16 at 18:44
1

Ensure you have a virtual host file set up for phpmyadmin within apache2/sites-available. You can just make a copy of 000-default and edit it with correct configuration then rename to phpmyadmin and run a2ensite phpmyadmin. Also ensure correct permissions are set to phpmyadmin directory. service apache2 reload for minor changes and restart for major changes, I prefer restart as it guarantees the changes will take effect.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.