I'm getting the following errors while trying to install Samba on a ubuntu server 10.04 LTS instance:

Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/s/samba/libwbclient0_3.4.7~dfsg-1ubuntu3.6_i386.deb 404 Not Found [IP: 80]

Is there any way to workaround this so I don't have to wait for the update servers to come back up? How do I prevent this in the future?

Edit: I found a very similar posting here on askubuntu: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/maverick/Release

But Lekensteyn's answer doesn't work (though it helped the author of the given question)... I still get the following (after switching repo's to in.archive.ubuntu.com):

root@orbital /home# apt-get install samba
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  samba: Depends: samba-common-bin but it is not going to be installed
         Depends: libwbclient0 (= 2:3.4.7~dfsg-1ubuntu3.4) but it is not going to be installed
         Depends: libtalloc2 (>= 2.0.0) but it is not installable
         Depends: update-inetd but it is not installable
E: Broken packages

If all else fails, how will I know when the repository is available again?

  • make a backup of /etc/apt/sources.list and then change your sources.list for all instances of "us." to "gb." i.e. the UK mirror. However can't answer your second part of your question, hence this is a comment not an answer. good luck! – fossfreedom Aug 3 '11 at 23:20
  • 1
    ... but this answer could help. askubuntu.com/questions/37753/… – fossfreedom Aug 3 '11 at 23:23

You need to run apt-get update to make sure that your package lists are up to date prior to installing packages.

In the case of samba, the current version is 2:3.4.7~dfsg-1ubuntu3.7.

|improve this answer|||||
  • Exactly what I was about to write. – Nathan Osman Aug 4 '11 at 0:43
  • I ended up using a different source, and it worked fine after the apt-get update. Thanks! – r00fus Aug 4 '11 at 17:22

Software Sources lets you select "Download from" which allows you to change the repository source. Perhaps a different choice will work for you. If you select "other", you'll find there are a lot to pick from even in the US. A button labelled "Select Best Server" will optimize your selection for performance.

|improve this answer|||||
  • I have no GUI, it's Ubuntu Server. – r00fus Aug 5 '11 at 4:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.