1

As stated in the title, I removed resolvconf (with reinstalling in mind because name resolution was acting up) but now I'm unable to install this package.
I tried two things:
apt-get install --reinstall resolvconf
resulting in the following error:

Package resolvconf is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'resolvconf' has no installation candidate

Using apt-get install resolvconf I get the same error.

1

Test this:

Open a terminal,

Press Ctrl+Alt+T

Run it:

sudo -i
wget http://fr.archive.ubuntu.com/ubuntu/pool/main/r/resolvconf/resolvconf_1.69ubuntu1_all.deb
dpkg -i resolvconf_1.69ubuntu1_all.deb
1

Grab the download URL domain:

$ sudo apt install resolvconf
...
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/pool/main/r/resolvconf/resolvconf_1.78ubuntu2_all.deb

Resolve it manually using OpenDNS server (provided you have nslookup, otherwise use some online DNS resolver):

$ nslookup fr.archive.ubuntu.com 208.67.220.220
...
Non-authoritative answer:
Address: 194.158.119.190

Edit your hosts file:

$ gksudo gedit /etc/hosts &>/dev/null &

Add:

194.158.119.190 fr.archive.ubuntu.com

Retry to reinstall resolvconf:

$ sudo apt install resolvconf

Disconnect / reconnect your network from network-manager.

Test.

Remove the now useless entry from your hosts file.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.