12

When I press Ctrl+Shift+u and type numbers, nothing happens. Holding down Control or Shift doesn't help, either.

I've tried running sudo dpkg-reconfigure keyboard-configuration, but that didn't solve the problem.

2 Answers 2

6

It hasn't stopped working in general, but the way it works may have led you to think that it has stopped working. When one types Ctrl+Shift+u an underscored letter u appears at the insertion point. This may lead a person (e.g., myself, at first) to think that he has entered an underscored letter u, whereas in fact the underscored letter u indicates the Unicode-entry mode has been activated. If one subsequently keys in a Unicode code point (i.e., the hexadecimal numeral for the character) and hits Enter then the unicode character will appear.

For example, Ctrl+Shift+u 2764Enter inserts a "heavy black heart" Unicode character.

Demonstration: ❤

6
  • 4
    The underlined U does not appear.
    – EMBLEM
    Jan 5, 2015 at 5:31
  • 2
    It stopped working for me too, must be some issue with GTK
    – MightyPork
    May 2, 2015 at 17:35
  • Just tested in gedit in Ubuntu 15.04. Worked fine.
    – jdthood
    May 3, 2015 at 19:25
  • It doesn't work for me on Ubuntu 14.04. It used to work on earlier versions of Ubuntu.
    – pts
    Oct 10, 2017 at 21:54
  • 1
    By the way, this answer bypasses the question entirely because the OP clearly knows how the ctrl+shift+u is supposed to work. It has stopped working for me since I upgraded to 20.
    – alife
    Nov 13, 2021 at 14:04
5

The reason why entering Ctrl+Shift+u, Unicode hexadecimal number, Enter or Space stop working in Ubuntu 15.10+ is because input method is by default XIM instead of iBus (which is odd since XIM is obsolete and iBus already implement XIM protocol). By changing this they broke this useful shortcut.

To fix it go to:

  1. On GNOME Shell (17.10+, check with wmctrl -m): Settings → Region & Language → Manage Installed Languages*

    On Unity: System Settings... → Language Support

  2. Keyboard input method system, change it to iBus. screenshot

  3. Restart

Reference

2
  • It hasn't stopped working. Please check the solution from jdthood
    – somethis
    Sep 3, 2019 at 9:45
  • @somethis, it has stopped working for many of us. The solution from jdthood isn't a solution: It's the way it was supposed to work, and I believe the OP knew this already with his question (he said "stopped working"). I can't get it to work in comments here, gmail, other edit fields, any editor, basically everywhere it used to work in 18.{mumble}.
    – alife
    Nov 13, 2021 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.