I just installed i3wm but I can't configure the $mod to be mod4 (Super aka "the Windows Key" in other OSes). I can only choose to use the mod1 (Alt).

I've tried reinstalling i3, and deleting the configure file to create a new one, without any good results. I really want to use Super because using Alt often conflicts with other program's short cuts.

Anyone else had this problem or have any suggestions on how I can fix this. I've used i3wm before with Ubuntu 12.04 LTS without any problems whatsoever.

  • Which repository did you use for installation of i3? – Charles Green Dec 5 '14 at 16:14
  • Ubuntu's by "sur5r". (i3wm.org/docs/repositories.html). I did the following in the terminal when I installed it: echo "deb debian.sur5r.net/i3 $(lsb_release -c -s) universe" >> /etc/apt/sources.list apt-get update apt-get --allow-unauthenticated install sur5r-keyring apt-get update apt-get install i3 – Spierdalaj Dec 5 '14 at 16:57

Run xev and whenever you press the super key you should see something like this:

KeyPress event ...
    root 0x25, subw 0x0, ...
    state 0x0, keycode 89 (keysym 0xffeb, Super_L), same_screen YES,

If this doesn't work I can't help you. If it does then just note the description of the key just after the keysym. It's Super_L in this example but it might be something else in your case. Now execute these commands:

xmodmap -e "clear mod4"
xmodmap -e "add Mod4 = Super_L"

*ATTENTION: make sure you replace Super_L with the description that xev prints to you in the above commands *

The curious can also run xmodmap -pm|grep mod4 in the end which should show mod4 Super_L

  • Any idea on how how to translate this answer to setxkbmap? – Calculus Knight Aug 26 '17 at 16:37
  • Sorry Knight - no idea. – ndemou Aug 26 '17 at 21:22
  • Thanks for the original answer, anyway. I made a new question that might bring an answer. – Calculus Knight Aug 26 '17 at 22:06

If xev isn't displaying anything when you press the key, make sure your keyboard isn't in a "gaming mode". I ran into this with a Logitech G710+. The button to toggle the mode looks like a little joystick and apparently one thing it does is disable the "Windows key". I assume it's to keep you from being pulled out of a full screen game if you miss pressing CTRL or ALT.

  • Same issue with my Logitech G610 Orion in Debian 10.1. Switching out of game mode (which had been on by default) allowed for it to register in xev. – davegallant Jan 15 '20 at 4:40
  • You are a life saver, I was pulling my hair about this problem – kisanme Dec 28 '20 at 6:47

I've got this issue on Ubuntu 18.04, where apparently my device has Fn + Super mapped to disable the super key. During this state, the Super key didn't work, and I couldn't switch to any of my tags (I'm using dwm). However, presing Fn + Super to toggle out made everything work again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.