I have a machine which is supposed to be a media server. I have tried to install Ubuntu (both alternate and regular i386). The installation (and boot to usb drive) went on fine, but after the install I tried to load the machine and it froze.

In the case of i386 I get the error "hd0 out of disk" and am left with a grub rescue console. set gives:


Following ubuntu wiki, I replaced msdos1 with 1 which didn't work.

In the case of the alternate install, I only get a blinking cursor on the top left (I waited for about two minutes).

If I wait a really long time in the alternate version, I get:

error: no such partition  
grub rescue>

Nothing works in this mode as well. I also tried to replace (hd0,1) with (hd0,sda) or (hd0,0) but this doesn't seam to have an effect.

Install information:

  1. Single hard drive
  2. Install on a hard drive via usb thumb drive
  3. Ubuntu's default hard drive portioning and formatting (use entire hard drive)
  4. Ubuntu Natty

How can I fix this?

  • ubuntu natty. I'm using usb thumb drive to install to hard disk. I have let ubuntu yo choose it's default partitioning (use and erase entire hard drive) – Yotam Aug 3 '11 at 21:00
  • Have you tried the recover options when running the install again from the thumb drive. I might also try re installing grub. If you can boot into a live environment. – nelaaro Aug 4 '11 at 9:05
  • Yes, I tried the recover operation after the new install. I don't think that re installing grub will work since this will be the exact same operation as the one carried by the install process. I'll try though... – Yotam Aug 4 '11 at 9:07
  • Is this a standard sata hard drive or a ssd hard drive. – nelaaro Aug 4 '11 at 9:08
  • @nelaar, This is an interesting question. I don't think this is a ssd since this is a cheap machine. The manufacture claims this is a SATA2 hard drive. I'm not sure since I remember this is a 320GB Toshiba hard drive with S.M.A.R.T technoligy while the link I posted state this is a 250 GB. When I'll get back home I'll check this. – Yotam Aug 4 '11 at 9:15

I would start with testing your hardware. It is probably not RAM but I would test that first anyway to prove it isn't a problem.

Next I would move onto the hard drive. You could try the diagnostics on the Ultimate Boot CD. There is a tool for most brands of hard drive. The other thing I would recommend is to try a different hard drive in your machine. Also changing USB cables if this is a desktop machine.

Hopefully at some point during this process you isolated the problem. If not then I think it is probably a software issue not hardware.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.