5

I am working with Ubuntu 14.04 (64bit) Unity. I have successfully integrated my gmail account in online-accounts. This works well, e.g. I can see my calendar events. I have also enabled the option "evolution data server - enable Google Contacts". However I am not able to access them on my system. If I open the application "Contacts" it shows no result at all.

So how can I access them?

  • First you need to tell Contacts to use local addressbook. First install evolution. Open it. Does your addressbook list appear on it? It should be under Google (YOURUSERNAME Label). Click on the addressbook. it should populate your Google contacts. If you are getting a authentication error then its probably a bug affecting Ubuntu 14.04. – Khurshid Alam Dec 5 '14 at 12:37
  • I will try to debug the bug & comment here. – Khurshid Alam Dec 5 '14 at 13:11
  • Hello. I did install evolution. If I click on contacts it shows an error: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._e_2dclient_2derror_2dquark.Code5: Legitimierung erforderlich – Felix Dec 20 '14 at 13:11
  • Yes. A bug has been filed. bugs.launchpad.net/ubuntu/+source/account-plugins/+bug/1399953. – Khurshid Alam Dec 20 '14 at 13:18
2

Here is a hack / workaround :)

NOTE: I should note that this was tested on Ubuntu 14.10 Also, first verify that you have enabled IMAP in your Gmail account settings.


Under “System Settings” → “Online Accounts” → “your Google Account”

  1. disable “Evolution Data Server: Access your Gmail”
  2. disable “Evolution Data Server: Access your Google Contacts"
  3. disable “Evolution Data Server: Access your Google Calendar"

Under “Evolution Preferences” → “Mail Accounts” → “Add”

I. At the account welcome screen click “Next”

II. Enter “Identity” information and click “Next”

III. Under "Receiving Email"

  1. under “Server Type” select the entry “IMAP+”

  2. under “Configuration”

    a. under “Server” enter “imap.gmail.com”

    b. under “Username” enter your full Gmail e-mail address

  3. under “Security”

    a. under “Encryption Method” select “SSL on dedicated port”

  4. under “Authentication”

    a. select “Password” from the drop down box

  5. click “Next”

IV. Under “Receiving Options” select your preferences

V. Under “Sending Email”

  1. under “Server Type” select the entry “SMTP”

  2. under “Configuration”

    a. under “Server” enter “smtp.gmail.com”

    b. check “Server requires authentication”

  3. under “Security”

    a. under “Encryption method” select the entry “SSL on dedicated port”

  4. under “Authentication”

    a. under “Type” select the entry “PLAIN”

    b. under “Username” enter your full Gmail e-mail address

VI. Under “Account Summary”

  1. under “Google Features”

    a. check “Add Google Calendar to this account”

    b. check “Add Google Contacts to this account”

0

Well after several month finally it seems to work.

According to the hint from Alberto on launchpad, I

  1. deleted my google account in the ubuntu online-accounts (which does not delete the google account itself).

  2. Afterwards I created the same google account again.

  3. After one reboot everything works fine at the moment.

However the must be some bug creating the problem in the first instance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.