7

I'm using Ubuntu Gnome 14.04 which is using gnome shell 3.10.4. I installed workrave through the terminal and the first time it launched the small window with the countdown timer displayed and it worked as it should. I closed the window and from then on I could never get it displayed again. I did an uninstall/reinstall, but that didn't work, and I also found out that the applet for workrave doesn't work in gnome shell. In the tweak tool settings under extensions the workrave option is greyed out and has a triangle warning sign.

The program can still be launched and works, but I can't set up my preferences because there's no window for me to interact with. Is there a way to bring back the workrave window so I can change my preferences?

1

Alright, so I happened upon the solution by playing around with the tweak tool. Basically you have to find the applet icon by turning on some non-default settings.

  1. Open Tweak Tool
  2. Go to Extension
  3. Turn on the Window list extension

Now there should be a tool bar at the bottom of the screen that displays all active apps. In the bottom right corner there should be a circle with a number in it , click on it and you should see the workrave applet icon (workrave needs to already be running).

After I set up my workrave preferences I just turned off window list.

  • 3
    I don't think this approach works anymore. I'm on Ubuntu 14.04.3 and I can't see "Window List Extension" on that "Extension" page of the Gnome Tweak tool – Rory Jan 10 '16 at 11:33
0

I tried this for XFCE, maybe workrave just doesn't work with gnome shell?

I tried installing a version of workrave directly from a single .deb file, but may not have installed everything it needed. It didn't make any program menu entires so I started it from a terminal also, and right-clicking on the icons didn't seem to work.

Just now I installed workrave from Synaptic (should be the same as apt-get install workrave ) and it installed 3 packages, had a programs menu entry, and right click shows preferences and settings, seems to work ok? Maybe yours installed strangely? Or as above, maybe it doesn't like gnome shell...

0

It started working (preferences and everything can be changed now finally) for me probably after I did this on ubuntu 14.04.

 $ sudo apt-get build essential 

and then it said I had to remove the redundant files.

 $ sudo apt-get remove autoremove

or probably because of the following :

I installed tweak tool, didn't find any of the things mentioned above by thorin and then just removed it and restarted it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.