1

I recently bought a new dell inspiron 15 7000. (this one)

I installed Ubuntu 14.04 LTS on this system. The trackpad/touchpad does not respond at all, I'm guessing is not identified.

xinput list:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=11   [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=15   [slave  pointer  (2)]
⎜   ↳ MSFT0001:00 06CB:75BD                     id=12   [slave  pointer  (2)]

I am somewhat new with Ubuntu and any help is appreciated.

  • I think it would be a good idea to try running Ubuntu 14.10 live and seeing if that fixes the problem. Also, I know that Ubuntu 14.10 has a nice feature that is supported on some Dell Inspiron 15 computers: it disconnects the hard drive when it detects it's falling. So yeah, try 14.10 LIVE and see if that helps. If it does, upgrade 14.04 to it using the Software Updater. – John Scott Dec 5 '14 at 1:37
  • FuzzyToothPaste: thanks for the response. Im not sure what you mean by LIVE. but when I use the bootable Image for ubuntu it still does not work. – saitiku Dec 5 '14 at 1:49
1

I just solved this problem.

I noticed that when ubuntu booted it showed some message saying :

[ 27.076007] i2c_hid i2c-SYN1B7D:01: failed to retrieve report from devce

I looked it up, and found this:
https://bbs.archlinux.org/viewtopic.php?id=185329

Same issue has been mentioned here :
https://wiki.ubuntu.com/TrustyTahr/ReleaseNotes/14.04#Kernel

This guy had almost same problem and it got solved by blacklisting i2c_hid module.

So if you just bought the same laptop and are facing the same problem, you can try doing this:

  • Open terminal and type in : sudo gedit /etc/modprobe.d/blacklist.conf. This is a file that has entries for kernel modules, that are not loaded or blacklisted.
  • Go to end of file and write this blacklist i2c_hid.
  • restart your system a couple of times . somehow I had to do it twice.

This solves this problem for now. Trackpad working perfectly.

  • Instead of restarting twice, shut down completely (power off) and then turn the machine on again... – Fabby Dec 5 '14 at 2:05
  • 1
    I recently received an update that caused my laptop's touchpad to stop working again. I removed the blacklist entry for i2c_hid. Now its working again. – saitiku Dec 10 '14 at 14:45
0

An update to kernel 3.18 solved it for me. Though on my system (with the updated kernel) the touchpad tends to freeze and become responsive again after a few seconds. Anyone else seeing this behavior?

  • I have not been having this problem anymore, and currently I am on kernel 3.19. So you maybe right – saitiku Feb 27 '16 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.