2

I am trying to get an Alfa Tube-U(N) USB Wifi adapter to work with Ubuntu 14.04.1 and getting stuck with actually connecting to any networks. It uses the Ralink RT3070 chipset (I think, based on lsusb output), and seems to be loading the rt2800usb kernel driver when plugged in on boot. An adapter wlan0 shows up when I run iwconfig but I cannot seem to configure it and it says "no wireless extensions". It does not show up under ifconfig. Here is the output from some relevant commands:

Lan Setup (other devices removed):

$iwconfig
wlan0     no wireless extensions.

Usb Devices:

$lsusb
Bus 002 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Kernel Modules:

$ lsmod | grep rt
rt2800usb              16519  0 
rt2800lib              78222  1 rt2800usb
rt2x00usb              11505  1 rt2800usb
rt2x00lib              46976  3 rt2x00usb,rt2800lib,rt2800usb
mac80211              477705  3 rt2x00lib,rt2x00usb,rt2800lib
cfg80211              424381  2 mac80211,rt2x00lib

Dmesg output relevant to this device (upon boot):

[   16.606242] usb 2-1: new high-speed USB device number 2 using musb-hdrc
[   16.764023] usb 2-1: device v148f p3070 is not supported
[   16.827013] usb 2-1: New USB device found, idVendor=148f, idProduct=3070
[   16.827042] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   16.827055] usb 2-1: Product: 802.11 n WLAN
[   16.827067] usb 2-1: Manufacturer: Ralink
[   16.827079] usb 2-1: SerialNumber: 1.0
[   19.396334] usb 2-1: reset high-speed USB device number 2 using musb-hdrc
[   19.821473] usbcore: registered new interface driver rt2800usb

I'm not sure how much it matters, but I am running this on a BeagleBone Black using the armhf version, as described here: http://elinux.org/BeagleBoardUbuntu#BeagleBone.2FBeagleBone_Black

0

I was able to configure the wireless device with iw and wpa_supplicant rather than iwconfig. I essentially followed the instructions here, which was based on this. Before doing so, I had to install iw with sudo apt-get install iw. The default installation may also need wpa_supplicant installed.

Bringing Up Step By Step After Boot

The wireless network can now be configured using the following minimum set of commands:

$ sudo ip link set wlan0 up
$ sudo -s
$ wpa_passphrase <SSID> >> /etc/wpa_supplicant.conf
<WPA passphrase>
$ wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant
$ sudo dhclient wlan0
$ sudo ip route change default via <gateway ip> dev wlan0

The last line assumes an ethernet network is already enabled, if not use add instead of change. The sites referenced above give a detailed explanation about the commands and additional ones to check the status of the connections and devices.

Automatic Configuration on Boot

There is another method to connect to the network at startup (and possibly with ifup/ifdown), by adding the configuration to /etc/network/interfaces. Mine looks like the following:

auto wlan0
iface wlan0 inet dhcp
    wpa-ssid "SSID"
    wpa-psk  "Password"
    post-up route change default via <gateway ip> dev wlan0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.