15

I downloaded Heroku from Heroku toolbelt using

wget -qO- https://toolbelt.heroku.com/install-ubuntu.sh | sh

in the terminal, which they recommended on their site. My Ubuntu (14.04.1) didn't recognize the -q0-, so I took it out. It then seemed to download fine - I see the in the directory I was in when i downloaded it.

Now, however, it still doesn't recognize heroku as a command. It also won't show me where it is with the 'whereis' command. But when I look in the current directory with ls -a, it shows up. It seems to be there.

How do I install it?

24

Just tried this now on 14.04. Here is how I did it, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo wget -qO- https://toolbelt.heroku.com/install-ubuntu.sh | sh

Once it finished installing, I typed heroku apps. see image below for more info.

enter image description here

| improve this answer | |
  • 1
    You might receive the following warning: "WARNING: The following packages cannot be authenticated! heroku heroku-toolbelt " . Then just run "apt-get install -y --force-yes heroku-toolbelt" – bogdan.rusu Nov 27 '16 at 12:14
10

You can install Heroku on Ubuntu 14.04 or any later version as a snap:

sudo snap install --classic heroku

This is published directly by Heroku. It updates automatically whenever they release a new version.

The more adventurous can install from the edge channel and get updates for every upstream commit:

sudo snap install --classic --edge heroku
| improve this answer | |
  • 4
    make sure /snap/bin is in $PATH – jfs Mar 11 '18 at 22:18
2

Configuring Heroku is quite straight-forward on DigitalOcean. After ssh-ing, run the following commands with sudo:

wget https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz -O heroku.tar.gz
tar -xvzf heroku.tar.gz
sudo mkdir -p /usr/local/lib /usr/local/bin

List the content of the current directory with ls. I found this output:

heroku-cli-v6.15.22-3f1c4bd-linux-x64  
heroku.tar.gz

This output determines the value in the next step, use the first file name in the next command:

sudo mv heroku-cli-v6.15.22-3f1c4bd-linux-x64 /usr/local/lib/heroku
sudo ln -s /usr/local/lib/heroku/bin/heroku /usr/local/bin/heroku

And that's it.

| improve this answer | |
  • 1
    These helped with setting up on WSL! Thanks :D – painotpi Apr 6 at 9:59
  • @pai.not.pi I'm extremely glad to be helpful :) – Zameer Apr 6 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.