2

I'm only asking this question because any other answer I found online to this problem didn't help me resolve it.

Basically I updated my Ubuntu 14.04 system last night and it asked me to restart my system. When I restarted it and logged in to my admin account the Unity interface didn't load. I could only see my background and Ubuntu 14.04 written in the bottom right corner of the screen. No shortcuts work like Alt+Ctrl+t to open the terminal, the mouse right click doesn't work either. I can only access the terminal with Alt+Ctrl+F1. I restarted the system several times and it was the same every time. I can, however, log in to another account which is not an administrator account, and that's what I'm using right now, but I don't have access to all my files from my admin account which I normally use.

I tried a number of solutions that people said worked for them in similar circumstances but none of them worked. I even installed gnome to see if that will help, but it didn't. Again I could only log in to the other non-admin account which displayed gnome without a problem, but the admin account didn't move past the background after login.

I even tried booting to another kernel in advanced options but that didn't work either.

I found the following solutions online which I tried but none of them worked:

sudo apt-get install unity-tweak-tool
unity-tweak-tool --reset-unity

Another one was:

sudo apt-get install compizconfig-settings-manager
export DISPLAY=:0
ccsm

Also this one:

sudo apt-get update --fix-missing

And this one:

sudo apt-get purge lightdm
sudo apt-get update
sudo apt-get install lightdm
dpkg-reconfigure lightdm
sudo shutdown

None of these worked. Can anyone please help me with this?

  • Try this to login to the admin account, sudo chmod -R ug+rwx /home/[username] – vembutech Dec 4 '14 at 11:21
  • 1
    I logged in to my admin account from the other account using sudo -i -u [admin_account_user] and was able to back up my entire home folder from there. I still can't access my firefox bookmarks though, which I also want to back up. I'm trying to figure out where firefox keeps the bookmarks on the file system. But other than that, I would still like to regain access to the admin account so I wouldn't have to reinstall the system. – SineLaboreNihil Dec 4 '14 at 11:33
2

As you have one user that works in the GUI and an admin that works in console mode, you have all you need to recover your system without re-installing it.

Log into the Admin account using Ctrl+Alt+F1 and type:

sudo adduser admin-new

Enter all info and then type:

sudo adduser admin-new adm 
sudo adduser admin-new cdrom
sudo adduser admin-new sudo
sudo adduser admin-new dip
sudo adduser admin-new plugdev
sudo adduser admin-new lpadmin
sudo adduser admin-new sambashare

log off and log on as admin-new using the GUI (if this doesn't work, report back here)

Open a terminal with Ctrl+Alt+T and type:

Warning! Do not try to be smart and do a cp --recursive /home/admin-old/* /home/admin-new/ as this will copy the error(s) you have in your current user settings!!!

cp --recursive --no-dereference /home/admin-old/Documents/* /home/admin-new/Documents
cp --recursive --no-dereference /home/admin-old/Downloads/* /home/admin-new/Downloads
cp --recursive --no-dereference /home/admin-old/Pictures/*  /home/admin-new/Pictures
cp --recursive --no-dereference /home/admin-old/Templates/* /home/admin-new/Templates
cp --recursive --no-dereference /home/admin-old/Desktop/*   /home/admin-new/Desktop
cp --recursive --no-dereference /home/admin-old/Music/*     /home/admin-new/Music
cp --recursive --no-dereference /home/admin-old/Public/*    /home/admin-new/Public
cp --recursive --no-dereference /home/admin-old/Videos/*    /home/admin-new/Videos

(Leave out the stuff you don't really need any more like the old Downloads directory or the Templates or …)

You now have 99% of all your stuff back! (if you do not have enough space to do the above all together, delete the original in-between copy commands)

If you want to copy any additional directories beyond those above, make a full system backup first because one of the directories you didn't copy contains the error.

Now do a: deluser --remove-home admin-old

  • 1
    Thank you very much for your answer. I was already able to copy everything from my old admin account, including the firefox bookmarks and was about to create a new admin account and just copy the old data back into this new account when all of a sudden everything in the old account started working again. I honestly don't know why it started working again but it just is, and that's the account I am using right now. None the less your solution was the same one I was about to apply just before my old account decided to cooperate again and load the GUI. – SineLaboreNihil Dec 5 '14 at 19:33
2

Instead of getting rid of all settings by coping only the data files to a new user, there is one more option to try first:

rm /home/{affected user}/.config/dconf/user
sudo service lightdm restart

This gets rid of the unity-related settings only, and for most problems like this, it is enough to get you back to a working state. It worked for me and saved hours of work compared to the other solution.

Source

  • Hours? Anyway, the solution above is a generic one that can be applied to any problem that is user-related and not system related... But yours is good too, so upvoted! ;-) – Fabby Aug 2 '15 at 11:27
  • Thanks for the upvote! You're right, your solution is more general. But in this case, mine is much quicker. If it saves hours... depends. ;) – Edgar Aug 2 '15 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.