0

I have a relatively fresh install of ubuntu 14.10. I am currently not able to ping www.google.com but I can successfully do ping 8.8.8.8 and I can successfully ssh into the machine from another computer on the network. I have tried removing/reinstall resolvconf with sudo apt-get remove --purge resolvconf && sudo apt-get install --reinstall resolvconf. The caveat here is that I can't resolve DNS so the re-install doesn't work. I checked out https://bugs.launchpad.net/ubuntu/+source/resolvconf/+bug/1308378 and tried pulling down the deb and doing the instructions listed there but I still cannot resolve any hosts. I have also tried editing /etc/resolv.conf and adding nameserver 8.8.8.8.

I haven't found any other solutions. The only other software I have installed is webmin, does anyone know of webmin causing issues?

Some additional information:

cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
         dns-nameservers 8.8.8.8 8.8.4.4

cat /etc/resolv.conf

nameserver 8.8.8.8
9
  • Flush all the entries in the iptables using the below command iptables --flush After this try to ping www.google.com – vembutech Dec 4 '14 at 4:33
  • Hmm! quiet strange. If you've internet access you should be able to ping public IP's. Without a proper DNS server, I doubt an FQDN will resolve. Are you using a static IP configured or through a DHCP? would like to see more information on those as well to assist further. – AzkerM Dec 4 '14 at 5:00
  • IP configured through DHCP however I did try changing it to a manually configured address to be sure. I can ping ip addresses fine but cannot resolve DNS entries for some reason. @vembutech there were no entries in the iptables so flushing didnt have any resolve the issue. – ajorgensen Dec 4 '14 at 5:04
  • Just to make sure that you're on the right track.. could you please post the output for cat /etc/network/interfaces and cat /etc/resolv.conf. – AzkerM Dec 4 '14 at 6:52
  • @AzkerM updated the question above with the information. – ajorgensen Dec 5 '14 at 4:24
1

Why are you putting the dns-nameserver on the loopback interface and not the physical interface which is connected to your network?

Here is what I have for one of my interfaces

# The primary network interface
auto eth0
iface eth0 inet static
        address 11.0.0.13
        netmask 255.255.255.0
        network 11.0.0.0
        broadcast 11.0.0.255
        gateway 11.0.0.1
        dns-nameservers 11.0.0.7 8.8.8.8

If you need step by step instructions, check out this article http://uglyvpn.com/2015/03/16/how-to-install-owncloud-on-ubuntu-14-10-using-hyper-v-part-3-of-3/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.