I would like to install the MS Truetype Fonts that come through the package ttf-mscorefonts-installer, so I did:

sudo apt-get install ttf-mscorefonts-installer

Accepting the license, the process completes without any errors. The fonts end up in


as expected. Just to be sure, I also did a

sudo fc-cache -f -s -v

which among other things says in its output:

/usr/share/fonts/truetype/msttcorefonts: caching, new cache contents: 60 fonts, 0 dirs

So far, so good (and inline with question How do I install fonts?) However, when I then open any font dialog (e.g. in OpenOffice or the font dialog of the terminal) I don't see all of the new fonts. For Arial, the standard form is missing, but bold and italic are there. Times New Roman is missing altogether.

I can use nautilus to browse to the font directory, double click the Arial.ttf file and see the font in all its beauty. I can even click the install button then and the font is copied over to my personal ./fonts directory and from there on visible to my apps. But it is not picked up from the system directory.

How do I get these fonts available system-wide for all users?

  • Do the fonts show up if you run fc-list as a user? If not, does clearing the contents of ~/.fontconfig/ help? – James Henstridge Aug 3 '11 at 13:24

Argh, by coincidence I just found the solution. There was a file called ~/.fonts.conf in my home directory that seems to come from Fontmatrix and had a list of rejected fonts, among them the ones I found missing. Simply deleting this file solved the problem. I remember that I had played around with Fontmatrix but I'm not sure what caused it to create this file. Anyway, problem solved.


I found out, after having similar problems, that in my folder (/usr/share/fonts/truetype/msttcorefonts) there was a file, saying that my licens failed - it gave me a command to use in the terminal to get prompted another licens agreement, which this time made it work.

Netflix Desktop worked like a charm after that! (well... truth be told, installations was needed, but it was all automatically done after that!)

  • 1
    Could you enter in more details? If I had the same issue, what steps should I follow to fix the problem? Edit your answer and add that information. – Braiam Sep 11 '13 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.