5

I am using Ubuntu for the first time. I enabled desktop sharing and tried RealVNC viewer (on Windows) to connect to it. However it failed with the message "Unable to connect to the VNC server using your chosen security settings". The connection dialog box has a drop down for Encryption, which defaults to "Let VNC Server choose" but there are four more options, I tried all but none of them works. Thus, assuming that it is some problem with Ubuntu's desktop sharing.

Research on the internet showed that disabling encryption (using dconf) resolves the problem link. The help on desktop sharing does not talk anything about this, thus I am not sure if I should follow that procedure. Besides what if I want encryption enabled? Also the solution asks to uncheck remote-access > enabled, isn't that disabling remote access?

I am hoping to get a solution from a expert and basically looking for the authentic method to correctly configure desktop sharing. Short answer followed by details would be appreciated.

Just reading this page and seems like it is discussing the known issue of Vino. Not yet sure which version of Ubuntu it applies to. But the problem is similar and the most likely solution is to install a different vnc server. (Not sure how it would integrate with desktop sharing application - will keep reading.)

  • If you do install a different VNC server, it won't integrate with that app (which is called vino-preferences, so...). – muru Dec 3 '14 at 23:14
  • @muru I figured out, but thanks, your note will be useful to other users. – RcnRcf Dec 4 '14 at 1:12
4

I mistakenly answered the question in the question section above. Copying the answer here...

Finally, after reading a few articles, I figured out the best possible solution:

  1. As Vino (Desktop Sharing) has issues, just don't use it.
  2. Access Ubuntu Software Center
  3. Search for vnc server
  4. x11vnc server turns up as the top rated server, install it.
  5. Enable/Disable SSL encryption, Listening on LocalHost or file transfer as the need be.
  6. Use a VNC client of choice on Windows and connect.

(I enabled SSL but my vnc viewer opens an unencrypted connection for some reason.)

Use ssvnc on Windows to fix this problem. I found this link helpful. Note v1.0.29 probably has a virus or a spyware (Firefox or Antivirus blocks it) use the earlier version.

| improve this answer | |
4

Thanks for the comments that gave me lots of insight, yet it did not work for me. In the end this is the way that I found.

In the target computer:

sudo apt-get install x11vnc
x11vnc -storepasswd (then enter some password)         
x11vnc -usepw [-ncache]

If you are trying to start the x11vnc server from a putty/ssh connection, try this:

x11vnc -usepw -display :0 [-ncache]

In the connecting computer:

vncviewer computer-name:1    

Done! And yes, connect to display :1, and then x11vnc will direct it to your display :0, and you can take over the control of mouse and keyboard.

| improve this answer | |
  • Did this solution work for you while using Unity, or did you have to install another Desktop Environment (like xfce) to make this to work? – jimm-cl Apr 28 '15 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.