0

Story:

Yesterday I wanted to make my Ubuntu partition bigger so I ran Windows (Dual boot) and decreased size of my D drive size. It wanted me to reboot computer, when it was starting up it done everything and rebooted once again. Then I saw grub rescue with "no filesystem" or something like that. I ran Ubuntu live CD to fix that and it is now working.

Problem:

Problem is when I want to add unallocated part of HDD to my Ubuntu partition I can't, because GParted thinks whole disk is unallocated! I tried fixing filesystem by: fsck /dev/sda5 -f -r, but I think that's not it (or I'm doing it wrong way). I have also tried chkdsk from Windows Installation CD, but it didn't fix anything. Also, both of systems are working.

Is it just GParted problem, or maybe HDD is bad for real? If so, how to fix it?

fdisk -l can see partitions:

root@ubuntu:/home/ubuntu# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa118d672

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   286719999   143256576    7  HPFS/NTFS/exFAT
/dev/sda3       286720000   811972349   262626175    7  HPFS/NTFS/exFAT
/dev/sda4       915726335   976771071    30522368+   f  W95 Ext'd (LBA)
/dev/sda5       915726336   968652799    26463232   83  Linux
/dev/sda6       968652800   976771071     4059136   82  Linux swap / Solaris

Images: enter image description here This is about partiton

merged by Mitch Dec 8 '14 at 17:16

This question was merged with GParted problems with swap and extended partition [duplicate] because it is an exact duplicate of that question.

  • @psusi Take a look here. There is a fdsik -l output before doing anything with partition table and after. – Jacajack Dec 8 '14 at 16:07